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Preface 

This manual describes the FactoryTalk View Product and System, the tasks 

to be performed on a system before installation, the detailed installation 

steps, how to use FactoryTalk Activation to license the installed product, 

tasks for deploying applications, and how to upgrade an existing system. 

The contents of this Installation and Deployment guide appear in the order 

you would use during installation on new or existing systems: 

 FactoryTalk View basics describes the software components and layout 

of the system (Chapter 1). 

 Hardware, operating system and domain information identifies 

requirements for the computers and operating systems (Chapter 2). 

 Preparing for installation gives you the information you need to get 

your computer systems ready for a new installation or an upgrade 

(Chapter 3). 

 Installation procedures walk you through the screens you will see 

during a complete installation (Chapter 4). 

 Activating the software is required to get software license information 

onto all the computers in your system (Chapter 5). 

 Deploying new applications covers several deployment types you may 

need (Chapter 6, 7, and 8). 

 Upgrading existing applications if you already have an installed HMI 

application and are upgrading to the latest version of FactoryTalk View 

(Chapter 9). 

In addition to FactoryTalk View Installation Guide, the FactoryTalk View 

documentation set includes: 

 FactoryTalk View Site Edition User’s Guide contains 

comprehensive information about designing and developing 

FactoryTalk View SE applications. 

The User's Guide is available in PDF format, from the Help menu in 

FactoryTalk View Studio, on the disc containing the Setup Wizard, and 

from the Rockwell Automation Literature Library. 

 Release Notes. Read the Release Notes before you begin installing or 

working with FactoryTalk View and supporting software.  

Release Notes for FactoryTalk View SE, RSLinx Enterprise, and 

RSLinx Classic are available from the FactoryTalk View Installation 

DVD. 

Release Notes for the FactoryTalk Services Platform are available from 

the Contents page in the FactoryTalk Help. To open the Help, select 

What’s in this 
Installation Guide? 

About the 
FactoryTalk View 
documentation 
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Start > All Programs > Rockwell Software > FactoryTalk Tools > 

FactoryTalk Help. 

 Help. Procedures and reference information are available from the 

Help menu in FactoryTalk View Studio, and from editors and dialog 

boxes used to develop FactoryTalk View SE applications. 

Find information in the FactoryTalk View 
installation 

Most of the dialog boxes during the installation include the selection View 

Installation Guide. Click the link to open the Installation Guide. 

You can also open the application release notes that contain the latest 

information about updates and program features. Click View Release Notes 

for the selected product. 

 

What’s in this manual 

The Installation Guide is available in PDF format from the FactoryTalk View 

Installation DVD, from the Help menu in FactoryTalk View Studio, and 

from the Rockwell Automation Literature Library. 

Tip: In the Literature Library, to find the current version of the 
Installation Guide and the User’s Guide, search for 
publication numbers containing the string VIEWSE. 

Chapters in this manual describe how to: 

 Set up the computers that will run FactoryTalk View SE. 
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 Install FactoryTalk View SE and supporting software. 

 Activate the FactoryTalk View SE software. 

 Deploy FactoryTalk View SE network and local applications. 

 Upgrade FactoryTalk View SE components. 

Each chapter includes a task check list, which you can use to create 

customized procedures suited to the needs of your application. 

Other Documents 

Document Description 

FactoryTalk Alarms and Events System 
Configuration Guide, publication FTAE-RM-001 

Describes the tasks to install, configure, and use FactoryTalk Alarms 
and Events services as part of a FactoryTalk-enabled automation 
system. 

FT Security System Configuration Guide, 
publication FTSEC-QS001 

Walk through of configuring FactoryTalk Security, creating accounts 
and setting permissions. 

 

Open FactoryTalk View manuals 

The FactoryTalk View Site Edition User’s Guide, Installation Guide, and the 

Release Notes are available online, while you are working in FactoryTalk 

View Studio. 

To open the manuals: 

1. Open FactoryTalk View Studio. 

2. From the Help menu, select Online Books, and then select the manual 

you want to open. 

Tip: During installation, Adobe Reader may be installed on 
the computer so that you can view online manuals. For 
information about using Adobe Reader, see the product 
documentation. 

 

If you cannot find the answer to your question in the documentation or on 

the Internet, contact Rockwell Automation Technical Support, using any of 

these methods: 

 Telephone: 1-440-646-3434 

 Online: http://support.rockwellautomation.com 

Contact Rockwell 
Automation 
Technical Support 
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Support staff are available Monday to Friday from 8:00 a.m. to 5:00 p.m. 

local time (North America only), except on statutory holidays. 

When you call Rockwell Automation Technical 
Support 

When you call, it is recommended that you be at your computer and ready to 

provide the following information: 

 The product’s Serial Number and Product Key, which are printed on 

the Activation Certificate enclosed with the product software DVD. 

 The FactoryTalk View product version number. 

 FactoryTalk Services Platform version number. 

 The connectivity (RSLinx Enterprise or RSLinx Classic) version 

number. 

 The type of hardware you are using. 

 The names of other Rockwell Automation products installed on the 

computer. 

 The exact wording of any messages shown on the computer. 

 A description of what happened and what you were doing when the 

problem occurred. 

 A description of how you tried to solve the problem. 

If you are running a FactoryTalk View SE network distributed application, 

also note: 

 How many computers are participating in the network application. 

 Whether computers on the network are connected using a Windows 

domain controller or a workgroup. 

 Which FactoryTalk View SE components are installed on participating 

computers. 

 Which computers are running servers (the Network Directory server, 

HMI servers, data servers, or tag alarm and event servers), and whether 

the servers are set up with redundancy. 

 Which computers are running clients (FactoryTalk View SE Client or 

FactoryTalk View Studio). 

Copyright notice 

© 2016 Rockwell Automation, Inc. All rights reserved. Printed in USA. 

Legal Notices 
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This document and any accompanying Rockwell Software products are 

copyrighted by Rockwell Automation, Inc. Any reproduction and/or 

distribution without prior written consent from Rockwell Automation, Inc. is 

strictly prohibited. Please refer to the license agreement for details. 

End User License Agreement (EULA) 

You can view the Rockwell Automation End-User License Agreement 

("EULA") by opening the License.rtf file located in your product's install 

folder on your hard drive. 

 

Trademark Notices 

Allen-Bradley, ControlLogix, Data Highway Plus, DH+, Data Highway II, 

FactoryTalk, Logix5000, MobileView, PanelBuilder, PanelView, PLC-2, 

PLC-3, PLC-5, Rockwell, Rockwell Automation, Rockwell Software, 

RSLinx, RSLogix, RSNetWorx, RSView, SLC, Studio 5000, VersaView, 

and XM are trademarks of Rockwell Automation, Inc. 

Any Rockwell Automation software or hardware not mentioned here is also a 

trademark, registered or otherwise, of Rockwell Automation, Inc. 

Other Trademarks 

ActiveX, Microsoft, Microsoft Access, SQL Server, Visual Basic, Visual 

C++, Visual SourceSafe, Windows, Windows ME, Windows NT, Windows 

2000, Windows Server, Windows 8.1, Windows 8, Windows 7, and 

Windows XP are either registered trademarks or trademarks of Microsoft 

Corporation in the United States and other countries. 

Adobe, Acrobat, and Reader are either registered trademarks or trademarks 

of Adobe Systems Incorporated in the United States and other countries. 

Oracle is a registered trademark of Oracle Corporation. 

ControlNet is a registered trademark of ControlNet International. 

DeviceNet is a trademark of the Open DeviceNet Vendor Association, Inc. 

(ODVA). 

Ethernet is a registered trademark of Digital Equipment Corporation, Intel, 

and Xerox Corporation. 

OLE for Process Control (OPC) is a registered trademark of the OPC 

Foundation. 

All other trademarks are the property of their respective holders and are 

hereby acknowledged. 



Preface 

 

14 Rockwell Automation Publication VIEWSE-IN003N-EN-E 

Warranty 

This product is warranted in accordance with the product license. The 

product’s performance may be affected by system configuration, the 

application being performed, operator control, maintenance, and other related 

factors. Rockwell Automation is not responsible for these intervening factors. 

The instructions in this document do not cover all the details or variations in 

the equipment, procedure, or process described, nor do they provide 

directions for meeting every possible contingency during installation, 

operation, or maintenance. This product’s implementation may vary among 

users. 

This document is current as of the time of release of the product; however, 

the accompanying software may have changed since the release. Rockwell 

Automation, Inc. reserves the right to change any information contained in 

this document or the software at any time without prior notice. It is your 

responsibility to obtain the most current information available from Rockwell 

when installing or using this product. 

Environmental compliance 

Rockwell Automation maintains current product environmental information 

on its website at 

http://www.rockwellautomation.com/rockwellautomation/about-us/sustainabi

lity-ethics/product-environmental-compliance.page 

http://www.rockwellautomation.com/rockwellautomation/about-us/sustainabi

lity-ethics/product-environmental-compliance.page 

Contact Rockwell Automation 

Customer Support Telephone — 1.440.646.3434 

Online Support — http://www.rockwellautomation.com/support/ 

http://www.rockwellautomation.com/support/ 

 

http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/support/
http://www.rockwellautomation.com/support/
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Chapter 1 

FactoryTalk View basics 

FactoryTalk View, including FactoryTalk View SE (Site Edition) and 

FactoryTalk View ME (Machine Edition), are HMI (human-machine 

interface) software products designed with a common look, feel, and 

navigation to help speed HMI application development and training time. 

Supporting the Rockwell Automation Integrated Architecture, FactoryTalk 

View is part of the scalable and unified suite of monitoring and control 

solutions designed to span stand-alone machine-level applications up through 

supervisory-level HMI applications across a network. This suite offers you a 

common development environment, application reuse, and architecture so 

you can increase productivity, reduce operation costs, and improve quality. 

FactoryTalk View includes the PC-based development tool FactoryTalk 

View Studio as well as FactoryTalk View ME and FactoryTalk View SE. 

FactoryTalk View SE is an integrated software package for developing and 

running HMI applications that can involve multiple users, clients, and 

servers, distributed over a network.  

FactoryTalk View SE provides all the tools you need to create powerful, 

dependable process monitoring and supervisory control applications. 

A FactoryTalk View SE System is more than the HMI Server and Clients. It 

also includes FactoryTalk Services Platform and Data Communication 

products such as RSLinx Enterprise and RSLinx Classic. 

What is FactoryTalk 
View SE? 
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About the architecture of your FactoryTalk View 
system 

A network distributed FactoryTalk View SE system consists of several 

components as shown below. 

 

This example of a distributed system includes a FactoryTalk Directory 

Server, FactoryTalk View SE Server and Client, RSLinx Enterprise Data 

Server, and FactoryTalk View Studio for application development and 

configuration. 

FactoryTalk View Studio Enterprise 

FactoryTalk View Studio Enterprise is the configuration software for 

developing and testing FactoryTalk View SE network distributed, network 

station, local station, and FactoryTalk View ME applications. 
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FactoryTalk View Studio contains editors for creating complete applications, 

and includes client and server software for testing the applications you 

create. Use the editors to create applications that are as simple or as complex 

as you need. 

 

FactoryTalk View SE Server 

FactoryTalk View SE Server, also called the HMI server, stores HMI project 

components (for example, graphic displays) and supplies them to clients. The 

server also contains a database of tags, and performs alarm detection and 

historical data logging. 

The FactoryTalk View SE Server has no user interface. Once installed, it 

runs as a set of headless Windows services that supply information to clients 

as they request it.  

FactoryTalk View SE Client 

FactoryTalk View SE Client is software for viewing and interacting with 

FactoryTalk View SE local station, network station, and network distributed 

applications at run time. 

Use the FactoryTalk View SE Client Wizard to create client configuration 

files that can be deployed to client host computers. For details, see the 

FactoryTalk View SE Client Help. 
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FactoryTalk View SE Station 

FactoryTalk View SE Station is a supervisory HMI software package for 

enterprise solutions. SE Station is a single-computer HMI that can be 

operated in either a Local or a Network FactoryTalk Directory. There are key 

differences between View SE Distributed and View SE Station: 

 View SE Distributed can share HMI screens and data with multiple 

clients. 

 View SE Station does not allow sharing of HMI screens or data to 

other View SE Stations. 

A Network Station deployment (below) can include several HMI stations 

using a single Directory server and a single RSLinx communication server. 

While each HMI station can access the same controller data, through the 

shared RSLinx Enterprise server, and the same Directory resources through 

the shared Directory server, they can only access their own HMI data such as 

graphics, macros, and datalogs. 

 

A Local Station FactoryTalk View SE system (below) can include several 

HMI computers, each with its own FactoryTalk Directory server and data 

server connection to the controllers. 
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Stand-alone RSLinx Enterprise Server 

RSLinx Enterprise is a FactoryTalk Live Data server and can be enabled as a 

FactoryTalk Alarms and Events server. Your applications use RSLinx 

Enterprise to communicate with devices such as controllers and I/O scanners. 

This enables you to see values, such as sensor readings and other controller 

data from your plant floor devices, on your desktop computer or dedicated 

PanelView Plus terminal. 

Stand-alone FactoryTalk Directory Server 

FactoryTalk Directory provides a central lookup service for a FactoryTalk 

system so all definitions do not have to exist in a single physical project file. 

References saved by FactoryTalk Directory are used by FactoryTalk-enabled 

products and FactoryTalk services to locate definitions when they are 

needed. It allows clients to locate key configuration information such as 

system organization, server locations, and policy information. FactoryTalk 

Directory provides a common address or phone book of factory resources 

that are shared among FactoryTalk-enabled applications in a distributed 

system. 

FactoryTalk Services Platform provides a set of common services (such as 

diagnostic messages, health monitoring services, and access to real-time 

data) for all the FactoryTalk products and applications used in a control 

system. 

FactoryTalk Services Platform is installed automatically with any 

FactoryTalk-enabled product. 

FactoryTalk Administration Console 

FactoryTalk Administration Console is a stand-alone tool for developing, 

managing, and securing multiple FactoryTalk View applications. 

To open the Administration Console, select Start > All Programs > 

Rockwell Software > FactoryTalk Administration Console. 

FactoryTalk Directory 

The FactoryTalk Directory centralizes access to system resources and names 

for all FactoryTalk products and components participating in an automated 

control system. 

The FactoryTalk Network Directory manages resources for FactoryTalk 

View SE network applications, and the FactoryTalk Local Directory 

manages resources for FactoryTalk View SE local applications. 

FactoryTalk 
Services Platform 
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FactoryTalk Alarms and Events 

FactoryTalk Alarms and Events, which installs behind the scenes during 

FactoryTalk View SE installation, provides system-wide alarm monitoring 

and control centralized at the FactoryTalk Directory. 

To distribute device- and tag-based alarms in a FactoryTalk View SE 

application, you can set up FactoryTalk Alarms and Events servers in the 

application. 

FactoryTalk Security 

FactoryTalk Security centralizes user authentication and authorization at the 

FactoryTalk Directory. 

FactoryTalk Live Data 

FactoryTalk Live Data manages connections between FactoryTalk products 

and data servers. 

FactoryTalk Diagnostics 

FactoryTalk Diagnostics collects and provides access to activity, status, 

warning, and error messages generated throughout a FactoryTalk system. 

How you plan to obtain data for an application will determine which 

communications software you install. 

You can use the RSLinx Enterprise or RSLinx Classic software shipped with 

FactoryTalk View SE, or use other software and devices that support OPC ( 

OLE for Process Control) communications. 

Tip: RSLinx Enterprise is automatically installed for 
FactoryTalk View applications. You may also choose to 
include RSLinx Classic during the installation procedure. 

 

RSLinx Enterprise 

RSLinx Enterprise is a communication server built around FactoryTalk 

technology to assist in developing and running your FactoryTalk View SE 

applications. 

Connectivity 
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For communications with Allen-Bradley local and remote devices, 

particularly with Logix5000 controllers, RSLinx Enterprise is the 

recommended data communications software for FactoryTalk View 

applications. 

However, RSLinx Enterprise does not allow you to create alias topic 

shortcuts, or to perform online tasks such as uploading and downloading 

RSLogix 5000 files. If you need these capabilities, you may use RSLinx 

Classic as your data communications server instead. 

RSLinx Classic 

RSLinx Classic is software that provides communications to a wide range of 

devices, such as Logix5000 processors. RSLinx Classic is an OPC Data 

Access v2.05a-compliant data server that can serve FactoryTalk Live Data 

tags from an HMI Tag database or RSLinx Enterprise. RSLinx Classic is 

available for personal computers only. 

For example, install and use RSLinx Classic to serve data through DH+ 

(Data Highway +) networks, to support complex bridging and routing, and to 

support unsolicited messaging from a controller to RSLinx. 

RSLinx Classic also allows you to create alias topic shortcuts, and to perform 

online tasks such as uploading and downloading RSLogix 5000 files. 

The FactoryTalk View DVD provides all the software you need to develop 

and run local applications confined to a single computer, or distributed 

control systems that involve several computers, connected over a network. 

Depending on needs, the architecture of a FactoryTalk View distributed 

application can involve multiple clients and servers that represent different 

parts of your plant or process. To accommodate those requirements, these 

FactoryTalk View programs are included in this Setup Wizard : 

 Studio Enterprise 

 Server 

 Client 

 Station 

 Stand-alone RSLinx Enterprise Server 

Installation DVD 
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 Stand-alone FactoryTalk Directory Server 

 

Tip: Three other applications can also be installed from this 
Setup Wizard for FactoryTalk View ME applications: 

 Studio for Machine Edition 

 Machine Edition Station for Windows 

 Stand-alone ME Transfer Utility 
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Chapter 2 

Hardware, operating system, and 

domain information 

This chapter introduces computer and Microsoft Windows support 

information for a FactoryTalk View SE system, including: 

 Review computer hardware requirements on page 23 

 Review operating system requirements on page 24 

 Set up Windows domain or workgroup on page 26 

 Set up computers with names to be used in production on page 28 

In a network application, it is possible for a single server computer that 

meets the listed hardware requirements to host all of the following 

components: 

 One FactoryTalk View SE Server 

 One RSLinx Enterprise data server (which can also be set up as 

FactoryTalk Alarms and Events device-based alarm server) 

 One RSLinx Classic OPC-DA server (or some other OPC data server) 

 One FactoryTalk Alarm and Event Tag based alarm Server 

 The FactoryTalk Network Directory 

However, running more than one HMI server on a single computer is not 
recommended. If you plan to deploy a network distributed application that uses more 
than two servers (or two pairs of redundant servers) and 20 clients, it is 
recommended that you contact your local Rockwell Automation Sales office for 
architectural assistance. For information about setting up redundant FactoryTalk View 
SE Servers, see Chapter 14, Setting up FactoryTalk system availability in the 
FactoryTalk View User's Guide VIEWSE-UM006. 

The computer hardware you choose to install and operate your FactoryTalk 

View SE System should be adequately sized for the demands of each 

component. These specifications are based on the hardware that the 

FactoryTalk View product and its supported operating systems require. 

Typically, application servers such as FactoryTalk View SE Server, 

FactoryTalk Alarms and Events, and RSLinx Enterprise will need to be sized 

with faster CPUs and more RAM than operator or engineering workstations. 

The greater the demand, the more powerful a system you need. 

What can I install 
and run on one 
server? 

Review hardware 
requirements 
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You should also specify a hard drive that has enough disk space to provide 

virtual memory that is at least twice the size of the physical RAM. 

For FactoryTalk View software upgrades in this release, we recommend 

upgrading your hardware to these levels. 

Type Description CPU RAM 

Operator Workstation FactoryTalk View SE Client 

or 

FactoryTalk View SE Station 

Intel Core 2 Duo and greater 2 GB or more 

Engineering Workstation FactoryTalk View Studio Enterprise 

RSLinx Classic 

RSLinx Enterprise 

Studio 5000 

Intel Core 2 Duo and greater 4 GB or more 

Application Server FactoryTalk View SE Server 

FactoryTalk View Studio Enterprise 

FactoryTalk Alarms & Events Tag 
Based Server 

RSLinx Enterprise Data Server with 
FactoryTalk Alarms and Events 
enabled 

Smaller System:  

Intel Core 2 Duo and greater 

2 GB or more 

Medium to larger systems: 

Quad core Intel Xeon family or 
greater 

4 GB or more 

 

Note: Do not run FactoryTalk Alarms and Events servers (Rockwell 
Automation Device Server or Tag Alarm and Event Server) on 
the computers that meet only minimum server requirements. 

 

FactoryTalk View SE software is designed to run on Microsoft Windows 

operating systems, including: 

Operating System 32-bit 64-bit 

Windows 8.1 Professional Yes Yes 

Windows 8.1 Enterprise Yes Yes 

Windows 8 Professional Yes Yes 

Windows 8 Enterprise Yes Yes 

Windows 7 Professional Yes Yes 

Windows 7 Professional with Service Pack 1 Yes Yes 

Windows 7 Enterprise with Service Pack 1 Yes Yes 

Windows 7 Ultimate with Service Pack 1  Yes 

Windows Server 2012 R2 Standard  Yes 

Windows Server 2012 R2 Datacenter  Yes 

Windows Server 2012 Standard  Yes 

Windows Server 2012 Datacenter  Yes 

Windows Server 2008 R2 Standard  Yes 

Windows Server 2008 R2 Standard with Service Pack 1  Yes 

Windows Server 2008 R2 Enterprise with Service Pack 1  Yes 

Review operating 
system 
requirements 



 Hardware, operating system, and domain information                  Chapter 2 

 

 Rockwell Automation Publication VIEWSE-IN003N-EN-E 25 

Windows Server 2008 Standard with Service Pack 2 Yes Yes 

The choices you make will depend in part on whether the computer is to host 

an application client or server. You might choose to run operator or 

engineering workstations in a Windows Server operating system, but that is 

not required. 

Recommended specifications for application servers are not as flexible, 

because server computers are more likely to host critical components and to 

handle more of the processing load in a FactoryTalk View SE application. 

Note: FactoryTalk View SE software is tested and supported on 
Windows operating systems installed from original Microsoft 
media only. Using unsupported operating systems is not 
recommended. 

 

Operating system recommendations for 
application servers 

For computers hosting application servers (HMI servers, data servers, or Tag 

Alarm and Event Servers), operating system requirements depend on whether 

the server will support more or fewer than 10 client connections. 

A client can be any of FactoryTalk View SE Client, FactoryTalk View 

Studio, the FactoryTalk View SE Administration Console, a FactoryTalk 

Transaction Manager connector, or another FactoryTalk View SE Server. 

For application servers that support: 

 More than 10 client connections, the recommended operating 

systems (with the appropriate number of CAL (client access licenses) 

installed) 

 Windows Server 2012 Standard Edition (64-bit) 

 Windows Server 2012 R2 Standard Edition (64-bit) 

 Windows Server 2008 Service Pack 2 (32-bit or 64-bit) 

 Windows Server 2008 R2 Standard Edition with Service Pack 1 

(64-bit). 

 10 or fewer client connections, the minimum requirement is 



Chapter 2                  Hardware, operating system, and domain information 

 

26 Rockwell Automation Publication VIEWSE-IN003N-EN-E 

 Windows 8.1 Professional (32-bit or 64-bit) 

 Windows 8 Professional (32-bit or 64-bit) 

 Windows 7 Professional (32-bit or 64-bit) 

Note: Do not run the primary and secondary servers in a redundant 
server pair on the computers that have different operating 
systems. For example, do not run the primary server on a 
Windows Server 2008 computer and the secondary server on 
a Windows Server 2012 computer. 

 

The number of computers participating in a FactoryTalk View SE network 

application determines whether the computers can belong to a Windows 

domain or a workgroup. 

Workgroups can be used only in applications that include 10 or fewer 

computers. Do not use Windows Workgroups with more than 10 computers, 

a Windows domain is recommended in that case. 

For more information about setting up domains and workgroups, see the 

document, FactoryTalk View SE Distributed System Design Considerations, 

attached to Rockwell Automation Knowledgebase Answer ID 32549. 

 A domain controller makes it possible to administer the network and 

user accounts from a central location. FactoryTalk Security, which 

manages centralized security services, supports Windows-linked 

accounts that are managed and authenticated by the Windows 

operating system, but have separate permissions for accessing the 

automation system. 

 Name resolution is required for the computers to communicate with 

each other on the network. 

 All computers participating in a single FactoryTalk system must be 

members of the same Windows domain. 

 Do not locate the domain controller on the same computer as any 

FactoryTalk software. Microsoft recommends against third party 

software being installed on a domain controller. 

Domain controller requirements 

For network applications consisting of more than 10 computers, the use of a 

domain controller is recommended. 

The following domain controllers are supported: 

 Windows Server 2012 (Standard Edition) 

 Windows Server 2012 R2 (Standard Edition) 

Set up the Windows 
domain or 
workgroup 
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 Windows Server 2008 with Service Pack 2 (Standard Edition) 

 Windows Server 2008 R2 with Service Pack 1 (Standard Edition) 

For more information about Windows operating systems and Service Pack 

compatibility, see Rockwell Automation Knowledgebase Answer ID 20450. 

Note: Do not install FactoryTalk Directory, FactoryTalk View 
SE Server, or any other application software on the same 
computer as the Windows domain controller. This 
configuration is not supported. 

 

About synchronizing time on application 
computers 

In a networked system, to ensure that time stamps on alarms, historical data, 

and diagnostics are accurate, it is highly recommended that time 

synchronization be configured on all application computers. 

For more information about synchronizing application computer clocks to an 

authoritative time server, see FactoryTalk View SE Design Considerations, 

attached to Rockwell Automation Answer ID 32549. 

Windows workgroup requirements 

For network applications consisting of 10 or fewer computers, you can run 

FactoryTalk View SE in a Windows workgroup network environment. 

 Name resolution is required for the computers to communicate with 

each other on the network. 

 Workgroups do not use a domain controller, so central network 

administration is not available. This means that security and network 

communications (for example, name resolution) must be handled at 

each individual computer in the workgroup. 

 Each workstation in a workgroup must have the same user accounts, 

with the same user names and passwords on each machine, for all 

machines participating in a client-server environment. 

 All users in a workgroup should have Administrative rights assigned to 

them. 

 FactoryTalk Directory provides centralized security services without 

requiring a Windows Server and domain controller. When setting up 

centralized security in a FactoryTalk Network Directory for Windows 

Workgroups, do not use Windows-linked accounts. Instead, create user 

accounts that are managed and authenticated by FactoryTalk Security. 
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When you install the FactoryTalk Services Platform with FactoryTalk 

View SE, the program creates a FactoryTalk account for the current 

computer, under the Local and Network FactoryTalk Directories. 

As a result, if you rename the computer after installing FactoryTalk View SE 

or when you deploy an application, the FactoryTalk Directory will not 

recognize the new name. 

To avoid this problem, it is recommended that you give the application client 

and server host computers the names they will use in a production setting, 

before you install the FactoryTalk View SE software. 

Tip: If you must rename a computer and you encounter 
problems, for assistance, see Rockwell Automation 
Answer ID 35169 (for FactoryTalk View SE network 
applications), or Answer ID 38775 (for FactoryTalk 
View SE local and ME applications). 

 

 

Set up computers 
with names to be 
used in production 
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Chapter 3 

Pre-installation configuration 

This chapter guides you through the steps for preparing your computer for 

installation of the FactoryTalk View SE product and supporting software. 

Use the following checklist for preparing the computer for installation: 

 Disable automatic Windows updates on page 29 

 Disable operating system themes on page 30 

 Manually configure NICs and switch ports on page 30 

 Disable or uninstall third-party firewalls on page 32 

 Remove Internet Explorer Enhanced Security Configuration on page 

33 

 Set up Data Execution Prevention on page 35 if needed 

 Remove unnecessary DCOM networking protocols on page 35 

When you install Microsoft Service Pack releases and other Windows 

operating system updates, you introduce new software that could affect the 

operation of FactoryTalk View SE components on the computer. 

Note: Windows updates should be disabled in all production 
computers. Updates can cause unexpected behaviors, 
including shutting down running applications and automatic 
computer reboots. 

To disable automatic Windows updates: 

1. Open the Windows Update window: 

 (Windows 7 or Windows Server 2008) 

Select Start > All Programs > Windows Update. 

 (Windows 8.1, Windows 8, or Windows Server 2012) 

Press the Windows button+X, select Control Panel > Windows 

Update. 

2. In the left column, select Change settings. 

3. In the Important Updates drop down, select Never check for 

updates. 

Disable automatic 
Windows updates 
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4. Select the check box Give me recommended updates the same way I 

receive important updates. 

5. Clear the check box Allow all users to install updates on this 

computer. 

For more information about Windows operating systems and Service Pack 

compatibility, see Rockwell Automation Knowledgebase Answer ID 20450. 

Operating system themes, which allow for effects such as sounds, icons, and 

other elements that personalize the computer, can cause heavy loads on the 

computer’s processor when running some FactoryTalk View SE graphic 

components, such as alarm summaries. 

For best performance, disable all themes. Follow the steps below. 

1. Open Control Panel: 

 (Windows 7 or Windows Server 2008) 

Select Start > Control Panel. 

 (Windows 8.1, Windows 8, or Windows Server 2012) 

Press the Windows button+X, select Control Panel. 

2. In Control Panel, click Appearance and Personalization. 

3. Under Personalization, click Change the theme. 

On the Themes tab, in the Theme list, click Windows Classic, and 

then click OK. 

The NIC (Network Interface Card) is the hardware in a computer that lets it 

connect to other devices on the network. A switch manages traffic on the 

Ethernet network. Some switches allow ports (physical connections) to be 

configured individually. 

The link speed and duplex settings for network connections can be 

auto-negotiated (the device determines the best way to communicate), or 

manually configured (settings are hard coded). 

Many NICs also offer a power-saving feature that turns off the network card 

if it is not being used. This setting sometimes interferes with the ability of the 

computer to receive data, causing errors such as wireframes, stale data, and 

other failures. To prevent these errors, disable power saving for your 

computer’s network interface cards. For details, see Disable power saving for 

the NIC on page 31. 

For FactoryTalk View SE applications, it is recommended that you use 

managed switches across the control system network and that you manually 

Disable operating 
system themes 

Manually configure 
NICs and switch 
ports 
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configure the same link speed and duplex setting for all network connections 

into the managed switches. 

It is also recommended that you manually configure the managed switch 

ports, using the same settings. To learn how to configure switch ports, see the 

product documentation provided with the switches you are using. 

For an overview of best practices for connecting devices over a network, see 

the Ethernet Design Considerations Reference Manual document in the 

Rockwell Automation Literature Library. (Search for publication  

ENET-RM002.) 

Note: If you are using unmanaged switches, the NIC settings must 
remain auto-negotiated. Connecting an auto-negotiated device 
to a manually configured device can result in network 
communication errors and is not recommended. 

 

Set up the NIC link speed and duplex 

Follow the steps below. The steps may vary slightly for some of the 

Windows operating systems. 

1. Open Windows Control Panel, and then click Network and Internet. 

2. From the list of categories, select Network and Sharing Center. 

3. From the list of Tasks on the left, select Change adapter settings (or 

Manage network connections). 

4. From the list of network connections, right-click Local Area 

Connection (or Ethernet), and then select Properties. 

5. In the Networking tab, click Configure. 

6. In the Properties dialog box for the device, click the Advanced tab. 

7. From the list of properties for the device, select Link Speed & Duplex 

(or Speed & Duplex). 

8. From the Value list, select the highest possible value for the 

connection, and then click OK. 

Disable power saving for the NIC 

Follow the steps below. The steps may vary slightly for some of the 

Windows operating systems.  
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1. Open Windows Control Panel, and then click Network and Internet. 

2. From the list of categories, select Network and Sharing Center. 

3. From the list of Tasks on the left, select Change adapter settings (or 

Manage network connections). 

4. From the list of network connections, right-click Local Area 

Connection (or Ethernet), and then select Properties. 

5. In the Networking tab, click Configure. 

6. In the Properties dialog box for the device, click the Power 

Management tab. 

7. Clear the Allow the computer to turn off this device to save power 

check box, and then click OK. 

FactoryTalk View SE is compatible only with the built-in Windows firewall 

and should not be used with third-party firewalls because this can cause 

unexpected results. 

Before installing FactoryTalk View SE, disable or uninstall all third-party 

firewalls on the computer. For details, see the documentation supplied with 

your firewall product. 

Microsoft Internet Information Services (IIS) is a critical service for a 

Distributed FactoryTalk View SE System. Because of this, the Setup Wizard 

detects whether Microsoft IIS is available on the computer and shows the 

status of that installation to the user. 

The following table shows whether IIS is required on your computers: 

IIS required IIS not needed 

 FactoryTalk View SE Server 

 FactoryTalk View Studio that needs to remotely connect to a 
Network FactoryTalk View SE system. 

 FactoryTalk View SE Client 

 FactoryTalk View Studio 

 Stand Alone RSLinx Enterprise Server 

 Stand Alone FactoryTalk Directory Server 

 

Guidelines for different operating systems 

Because of different versions and configurations for IIS, you may need to 

perform manual steps for older operating systems before installing 

FactoryTalk View SE. Microsoft has also changed its policy of including a 

key IIS component, WebDAV, in various operating systems. This also will 

require manual steps to download and install WebDAV for older operating 

systems. 

Disable or uninstall 
third-party firewalls 

Install IIS 
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By default, IIS is installed by FactoryTalk View Setup Wizard automatically. 

If you have problems with the IIS setting, refer to Install Microsoft Internet 

Information Services on page 133. 

If you are using Windows Server 2008 with Service Pack 2, you need to 

manually download WebDAV from Microsoft and install it. 

About uninstalling IIS 

If for some reason, you need to uninstall and then reinstall IIS, after 

reinstalling, you need to recreate the virtual directories in IIS.  

To recreate the virtual directories, in Windows Explorer, open C:\Program 

files\Rockwell Software\RSView Enterprise and double-click 

RSViewWebManager.exe. 

Internet Explorer Enhanced Security Configuration (ESC) is a group of 

default security settings for Windows Server 2008 and Windows Server 

2012 that protects servers by limiting the ways users can browse Internet and 

Intranet Web sites on the computer. 

If installed on a computer with FactoryTalk View SE software components, 

the Internet Explorer ESC can interfere with the ability of FactoryTalk View 

SE Clients to connect to application servers. 

To avoid unexpected behavior, it is recommended that you remove the ESC 

from computers running FactoryTalk View SE. 

To remove ESC in Windows Server 2008: 

1. Select Start > Administrative Tools > Server Manager. 

Remove ESC 
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2. In the Server Manager window, under Security Information, click 

Configure IE ESC. 

 

3. In the Internet Explorer Enhanced Security Configuration dialog, 

select Off to turn off IE Enhanced Security for Administrators and for 

users, and then click OK. 

 

To remove ESC in Windows Server 2012: 

1. On the Windows taskbar, select the Server Manager icon. 
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2. In the Server Manager Dashboard window, on the left side, click 

Local Server. 

3. On the right side of the Local Server window, under Properties, 

locate IE Enhanced Security Configuration and click On. 

4. In the Internet Explorer Enhanced Security Configuration dialog, 

select Off to turn off IE Enhanced Security for Administrators and for 

users, and then click OK. 

Data Execution Prevention (DEP) is a Microsoft Windows security feature 

that is built into the operating system starting with Windows XP and 

Windows Server 2003. DEP is intended to protect programs and services 

from viruses and other security threats. 

The DEP settings determine which programs and services are covered by 

DEP protection. On computers running FactoryTalk View SE components, it 

is recommended that DEP be turned on for essential Windows programs and 

services only. 

To turn on DEP: 

1. Open Windows Control Panel, select Control Panel Home > System 

and Maintenance. 

2. Click System. 

3. From the list of tasks on the left, select Advanced system settings. 

4. In the System Properties dialog box, click the Advanced tab. 

5. In the Advanced tab, under Performance, click Settings. 

6. In the Performance Options dialog box, click the Data Execution 

Prevention tab. 

7. Select the option, Turn on DEP for essential Windows programs 

and services only, and then click OK. 

If multiple DCOM protocols are installed and configured on the computer, 

performance of communications in a FactoryTalk View SE system can be 

adversely impacted. To ensure that DCOM communications function 

correctly, and do not affect the performance of the system, remove all 

protocols other than TCP/IP. 

To remove unnecessary DCOM protocols: 

1. Select Start > Run. 

2. In the Run dialog box, type dcomcnfg, and then click OK. 

Set up DEP 

Remove 
unnecessary DCOM 
networking 
protocols 
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3. In the Component Services tool, expand Component Services, open 

the Computers folder, right-click My Computer, and then select 

Properties. 

4. Click the Default Protocols tab. If the DCOM Protocols list shows 

protocols in addition to TCP/IP, remove those unnecessary protocols. 

For example, remove the protocol Connection-oriented SPX. 
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Chapter 4 

Installing FactoryTalk View 

The FactoryTalk View installation DVD provides all the software you need 

to develop and run distributed systems involving multiple computers on a 

network, or local applications confined to a single computer using 

FactoryTalk View Site Edition (SE). 

This chapter uses FactoryTalk View Studio Enterprise to illustrate the 

installation steps, because it includes all mandatory and optional installation 

choices included with the other selections on the welcome screen. 

To learn about upgrading an existing version of FactoryTalk View SE, see 

Upgrading an operating FactoryTalk View SE application on page 99. 

FactoryTalk View supports two installation methods: Setup wizard 

installation and unattended installation. 

The unattended installation reduces user interaction and provides command 

line parameters to install FactoryTalk View products. See Use unattended 

installation on page 137. 

This chapter uses the Setup wizard installation method to illustrate the steps. 

The overall installation process includes: 

1. Decide which FactoryTalk View SE components to install on page 38 

2. Prepare for installation on page 39 

3. Launch Setup Wizard and select what to install on page 39 

4. Setup common product and install IIS on page 40 

5. Provide information for the installation on page 43 

6. Check selections and start the installation on page 50 

7. Complete installation on page 51 

8. Install SE clients in a distributed system on page 52 

9. Post-installation procedures on page 54 

Steps to install 
FactoryTalk View 
SE 
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The FactoryTalk View Setup Wizard offers several options for installing the 

FactoryTalk View Site Edition software. You can select: 

 Studio Enterprise 

 Site Edition Server 

 Site Edition Client 

 Site Edition Station 

 Stand-alone RSLinx Enterprise Server 

 Stand-alone FactoryTalk Directory Server 

The option you choose depends on the type of FactoryTalk View Site Edition 

application or software component you plan to run on the computer and on 

the design of your control system. 

For each selection on the Welcome Screen, the following table shows the 

mandatory, recommended and optional software components to install. 

Selected Application Mandatory Applications Recommended and Optional 

Studio Enterprise FactoryTalk View Studio Enterprise 

FactoryTalk Services Platform 

FactoryTalk Activation Manager 

FactoryTalk Alarms and Events 

RSLinx Enterprise 

FactoryTalk View SE Server 

FactoryTalk View SE Client 

Device Status and Diagnostics Faceplates 

RSLinx Classic 

FactoryTalk Historian Connectivity 

Site Edition Server FactoryTalk View SE Server 

FactoryTalk Services Platform 

FactoryTalk Activation Manager 

FactoryTalk Alarms and Events 

RSLinx Enterprise 

FactoryTalk View SE Client 

RSLinx Classic 

 

Site Edition Client FactoryTalk View SE Client 

FactoryTalk Services Platform 

FactoryTalk Activation Manager 

FactoryTalk Alarms and Events 

FactoryTalk Historian Connectivity 

Site Edition Station FactoryTalk View SE Server 

FactoryTalk View SE Client 

FactoryTalk Services Platform 

FactoryTalk Activation Manager 

FactoryTalk Alarms and Events 

RSLinx Enterprise 

FactoryTalk View Studio 

Device Status and Diagnostics Faceplates 

RSLinx Classic 

FactoryTalk Historian Connectivity 

 

Stand-alone RSLinx 
Enterprise Server 

RSLinx Enterprise 

FactoryTalk Services Platform 

FactoryTalk Activation Manager 

FactoryTalk Alarms and Events 

RSLinx Classic 

 

Stand-alone FactoryTalk 
Directory Server 

FactoryTalk Services Platform 

FactoryTalk Activation Manager 
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install 



 Installing FactoryTalk View                  Chapter 4 

 

 Rockwell Automation Publication VIEWSE-IN003N-EN-E 39 

To prepare for the installation: 

 Ensure that the user installing the software has administrative rights in 

Windows. 

 If installing FactoryTalk View Studio Enterprise, locate the serial 

number because you will be prompted for it during the installation. 

Serial numbers are generally on the original packaging of the 

installation media. 

 Schedule downtime for the system if you are upgrading operating 

applications or replacing computers during the installation. 

To launch the Setup Wizard and select the product to install: 

1. Close all open Windows programs. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double click Setup.exe within the installation package. 

Tip: If the installation does not start automatically, 
double-click D:\Setup.exe, where D:\ is the drive 
containing the DVD. 

3. The Welcome screen offers a pull down menu to select the products 

you would like to install. 

 

4. Select the appropriate product for the computer you are upgrading or 

installing. 

Tip: Information about Studio for Machine Edition and 
Machine Edition Station for Windows appears in 
FactoryTalk View Machine Edition Installation Guide 
VIEWME-IN007. 

5. Adobe Reader will be installed unless you clear the check box. Adobe 

Reader is required to open the Installation Guide, User Guide, and 

other manuals. 

Prepare for 
installation 

Launch Setup 
Wizard and 
selecting what to 
install 
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6. After you make the selection from the list, the Setup Wizard will 

automatically offer different choices for the software products to 

install. Make your choices and click Next. The applications you have 

selected will determine the sequence of installation. 

7. Follow the prompts for the product you have selected. 

On the Rockwell Software Common Setup page, there may be three 

different options displayed: 

 Mandatory (greyed-out and checked) software that will be 

automatically installed as part of the selected application. 

Tip: If a product is already installed, it will be greyed out with 
an unchecked check box. 

 Recommended (check box with a green check) indicates software that 

Rockwell recommends for the application. You may decide to uncheck 

the box so the software does not install. 

 Optional (clear check box) indicates software that you may wish to 

include depending on your system. Check the box to include the 

software during installation. 

When a new product from the middle selection box is selected, version and 

upgrade information is shown in the right text box. If applicable, information 

about the previous version is also displayed in the right text box. 

Make any changes desired and click Next to proceed. 

 

Setup common 
products and install 
IIS 
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FactoryTalk activation warning 

Some products require activation using FactoryTalk Activation Manager. 

Even if you previously used a different method of activation, all FactoryTalk 

View software must be activated using FactoryTalk Activation Manager. 

Click Next to proceed. 

 

IIS check and installation 

The Setup Wizard automatically installs Microsoft Internet Information 

Services (IIS) if needed. Click Install IIS to proceed. 
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After selecting Install IIS, you will see the text appear in this screen at the 

top: 

Installing IIS - This may take several minutes, please wait… 

Once the IIS installation is complete, the text will appear in this screen at the 

top: 

IIS is installed correctly, please click Next to continue. 

Tip: For Windows Server 2008 SP1 and SP2 running network 
applications, the WebDAV module must be installed in 
IIS. Click on Download WebDAV to download and install 
the extension from the Microsoft website. 

After IIS and WebDAV are installed as needed, click Next to proceed. 

Dependent software process termination warning 

During the installation, the Setup Wizard identifies Rockwell Automation 

software that will be replaced. The program automatically terminates the 

programs listed on the following dialog box. 

Note: This procedure could shut down your process 
applications! Depending on which applications you are 

installing or upgrading, it is possible that your factory 
automation system will become inoperable, shutting down 
your processes. Be certain you have prepared for this 
downtime and all of your company’s systems are prepared for 
these applications to be terminated. 

Click Next to proceed. 

 



 Installing FactoryTalk View                  Chapter 4 

 

 Rockwell Automation Publication VIEWSE-IN003N-EN-E 43 

The Setup Wizard will only show this Serial Number entry page when 

FactoryTalk View Studio Enterprise is selected for installation. All other 

product serial numbers will be entered through the FactoryTalk Activation 

Manager after the installation is complete. 

User name and organization are optional and not required for all installations. 

A serial number reveals which edition of FactoryTalk View you purchased. 

Valid serial numbers are important to get activation keys and call Technical 

Support. If you do not enter a valid serial number, you will be allowed to 

proceed with the installation. Serial number information is available from the 

product packaging. 

Enter the serial registration information and click Next. 

 

Provide information 
for the install 
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End User License agreement 

End-user license agreements (EULA) spell out your rights and 

responsibilities. Depending on the applications being installed, it is possible 

that there may be more than one license agreement on this page. The 

individual license agreements are listed above the text box. 

 

Some software products may be delivered or made available only after you 

agree to the terms and conditions of each of the license agreements. 

To accept the license agreements: 

1. Select an agreement at the top of the dialog box to read the license 

agreement. 

2. Repeat for each license agreement. 

3. When all license agreements have been read, click Accept All to agree 

with the terms of all the listed license agreements and continue. 

If you do not accept the terms of the license agreements click Decline. 

The Setup Wizard will end. 

To return to the previous screen, click Back. 

File location for product installation 

Select the location for Rockwell Automation software. If needed, select the 

pull down menu to browse to another drive location. 
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Once the drive is selected, click Next. 

 

Select Setup Type 

This dialog box allows you to select the most appropriate type of installation 

for your applications. 

 Complete installs all the components available in the Setup Wizard. 

 Custom allows you to select optional components such as Help and 

demo applications. 

Select a setup type and click Next. 
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SQL Server sign-in or installation 

During the installation, the Setup Wizard determines whether a compatible 

SQL server is available on the computer. 

 

FactoryTalk View Site Edition tag database supports the following editions: 

 SQL Server 2008 R2 Express (32-bit or 64-bit) 

 SQL Server 2008 R2 Standard (32-bit or 64-bit) 

 SQL Server 2008 R2 Enterprise (32-bit or 64-bit) 

If a supported edition of FTVIEWx64TagDB instance exists, the installer 

skips the SQL configuration step. 

If it is not already installed, the Setup Wizard will prompt for a new 

password and will ask to verify the password as shown above. 

Tip: To use other compatible SQL Server editions, you need 
to manually install it. Click Compatible Editions for 

instructions or see Install compatible SQL Server editions 
on page 47 

New passwords must be strong passwords. Click Guidelines to review the 

requirements for strong passwords. 

Enter and verify the password, then click Next. 

Note: The chosen password should be recorded and saved along 
with other administrator passwords for system maintenance 
personnel. 
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Strong password guidelines 

Strong passwords are not readily guessed by a person, and are not easily 

hacked using a computer program. Strong passwords cannot use prohibited 

conditions or terms, including:  

 A blank or NULL condition 

 Password 

 Admin 

 Administrator 

 sa 

 sysadmin 

A strong password cannot be the following terms associated with the 

installation computer: 

 The name of the user currently logged onto the machine 

 The computer name 

A strong password must be more than 8 characters in length and satisfy at 

least three of the following four criteria: 

 It must contain uppercase letters 

 It must contain lowercase letters 

 It must contain numbers 

 It must contain non-alphanumeric characters; for example, #, %, or ^ 

Install compatible SQL Server editions 

FactoryTalk View Site Edition provides a batch file that you can use to 

install the SQL Server edition with minimal user intervention. Follow the 

steps below: 

1. Close all open Windows programs, including FactoryTalk View setup 

program. 

2. Open the Command Prompt window: 
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 (Windows Server 2012, Windows 8.1, and Windows 8) Press the 

Windows button+R. In the Open text box, input cmd and click 

OK. 

 (The other supported operating systems) From the Windows Start 

menu, select All Programs > Accessories > Command Prompt. 

3. In the Command Prompt window, navigate to the following directory 

where D:\ is the drive containing the disk: 

D:\Redist\SQLServerEXPR_2008R2SP2 

In this example, type the following command and press Enter: 

cd /D "D:\Redist\SQLServerEXPR_2008R2SP2 

4. Type a command line with the following syntax: 

"Install Compatible SQL.bat" [SQL setup.exe path] 

[Product key] [SA password] 

where 

 [SQL setup.exe path] Specifies the full path of SQL Server 

setup.exe, for example, E:\setup.exe. 

 [Product key] Specifies the SQL Server product key. 

 [SA password] Specifies the SQL Server System Administrator 

(SA) password. 

All parameters are required. 

Example: If your SQL Server setup.exe is under the drive E:, the 
product key is 01234-56789-ABCDE-FGHIJ-KLMNO, and 
the SA password is mySaPwd@123, type the following 
command: 

"Install Compatible SQL.bat" 

E:\setup.exe 

01234-56789-ABCDE-FGHIJ-KLMNO 

mySaPwd@123 

5. Press Enter. The installation starts. Follow the on-screen instruction to 

complete the installation. 
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Configure products 

If you selected the Custom setup, you can decide whether to install the demo 

applications and help files when performing a FactoryTalk View Studio 

Enterprise installation. 

 

Under the FactoryTalk View Site Edition Server application, you can also 

decide whether to install the client install portal feature. The feature allows 

you to install Site Edition Client through a web browser in a distributed 

system. For more information about the feature, see Installing SE clients in a 

distributed system on page 52. 
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Tip: Make sure to select the Client Install Portal check box 

at the first time if you plan to use this feature. Otherwise, 
you will not be able to add and install it in the Program 
Maintenance mode. 

Some other applications may not provide any choices. 

Click Next to continue. 

Once all the selections are made, the Setup Wizard displays the prerequisites 

and Rockwell software that will be installed. 

 Configuration Summary indicates the software that will be included 

in the installation process. 

 Prerequisite Software is required on the computer to support the 

Rockwell Software applications. 

 Rockwell Software applications are the Rockwell applications queued 

for installation. 

This step shows you the list of software that will be installed based on the 

selections made in the Setup Wizard. 

Select the software names to show descriptions in the bottom text window. 

To make a different product selection, click Back. 

If everything in the list looks okay, click Install to start the installation 

process. 

 

Check selections 
and start the 
installation 
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Start the installation process 

After installing prerequisites, the installer automatically installs all the 

Rockwell Software applications selected previously. Installation is automatic 

and does not require any input from the user. 

Installation status updates are provided at the bottom, just above the progress 

bar. 

 

When the installation completes, the Setup Complete page opens. 

To receive the patch notification when you install Rockwell software, click 

Register for updates and subscribe. 

To proceed directly to activation of the installed components, click Finish. 

You can also clear the check box for Activate products using FactoryTalk 

Activation to finish without activation. See Activate FactoryTalk View 

software on page 57. 

Complete the 
installation 
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After you click Finish, you will be prompted to restart the computer. Click 

Yes to restart now. Click No to restart later. 

 

In a distributed system, after installing the server computer with the client 

install portal feature, you can install SE clients through the web browser. 

To install the SE client application: 

1. On the client computer, open Internet Explorer. 

2. In the Address field of Internet Explorer, type the following address: 

http://servername/ftviewclient 

where servername is the name of your FactoryTalk View SE server 

computer. 

For example, if your FactoryTalk View SE server is called 

MYSERVER, type: 

http://MYSERVER/ftviewclient 

If you are using SSL, then begin with https:// instead. 

3. Press Enter. 

Install SE clients in 
a distributed system 
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Internet Explorer displays a page from the server that allows you to 

install the FactoryTalk View Site Edition Client application. 

 

Tip: If Internet Explorer displays an error message that it 
cannot connect to the install web page, try adding the 
FactoryTalk View Site Edition website (URL above) to 
your local intranet site list. 

To do this, in Internet Explorer, click Tools > Internet 
Options > Security tab > Local intranet > Sites > 
Advanced, and add the website to the list. For more 

information about the local intranet, refer to Windows 
Help and Support. 

4. Microsoft .NET Framework 4.0 is required before you can install 

FactoryTalk View Client. If it is not installed, click Install .NET 

Framework 4.0 on this computer. The option is not shown if it is 

already installed. 

5. Follow the on-screen instructions. If prompted to restart your 

computer, click Restart Now. 

6. Once the computer has restarted, repeat steps 1 to 4. 

7. To install SE Client, click Install FactoryTalk View Site Edition 

Client on this computer. Follow the on-screen instructions.If you are 

displaying data from FactoryTalk Historian on trends, click Install 

FactoryTalk Historian Connectivity tools. Follow the on-screen 

instructions to complete the installation. 

Tip: FactoryTalk Historian Connectivity allows the TrendX 
object to retrieve data from a Historian SE Server or 
Historian ME Module. It makes updates to FactoryTalk 
Administration Console and FactoryTalk View SE Studio 
to display an Historian icon for both Historian SE and 
Historian ME when they are registered. You can use it to 
create new Historian SE points from TrendX and select 
existing Historian points from Historian SE or Historian 
ME. 
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Now that FactoryTalk View product has been installed, there may be several 

final setup steps that must be completed: 

 Install product updates on page 126 

 Specify the Network Directory server location on page 54 

Specify the Network Directory server location 

Use the FactoryTalk Directory Server Location Utility on all application 

server and client computers to specify the computer that will host the 

FactoryTalk Network Directory server. 

To set up the local computer as the Network Directory server: 

1. On the Network Directory computer, click Start > All Programs > 

Rockwell Software > FactoryTalk Tools, and then click Specify 

FactoryTalk Directory Location. 

You will have to log on as an administrator on the local computer. 

2. If localhost is displayed in the field under Computer hosting directory 

server, the computer is already specified as the Network Directory 

host. You can close the utility. 

If localhost is not displayed, click the Browse button. 

3. In the FactoryTalk Directory Server Configuration dialog box, click 

This computer, and then click OK. 

4. Click OK again, to close the FactoryTalk Directory Server Location 

Utility. 

To specify the Network Directory on client and server computers: 

1. On the Network Directory computer, click Start > All Programs > 

Rockwell Software > FactoryTalk Tools, and then click Specify 

FactoryTalk Directory Location. 

2. If a remote computer is hosting the Network Directory server, click the 

Browse button beside the field, Computer hosting directory server. 

3. In the FactoryTalk Directory Server Configuration dialog box, click 

Remote computer. 

4. Type the name of the Network Directory server computer, or click the 

Browse button to find and select the computer, and then click OK. 

You will have to log on as an administrator on the remote computer. 

Post-installation 
procedures 
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5. Click OK again, to close the FactoryTalk Directory Server Location 

Utility. 

Repeat steps 1 to 5 on all client and server computers that will participate in 

the deployed network distributed application. 
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Chapter 5 

Activating FactoryTalk View 

software 

For continuous use of FactoryTalk View SE and other Rockwell Software 

products, computers running the software must have access to activation 

files. 

To manage and provide activations for FactoryTalk View SE software 

components, use the FactoryTalk Activation Manager installed with 

FactoryTalk View. 

FactoryTalk Activation Manager provides a secure, software-based system 

for activating Rockwell Software products and managing software activation 

files. 

With FactoryTalk Activation Manager, there is no need for a physical master 

disk or any physical media; instead, activation files are generated and 

distributed electronically. 

FactoryTalk View SE products use two types of activations: 

 Floating concurrent activations are checked out of an activation server 

located on the network, and require a continuous network connection. 

 Borrowed concurrent activations are time-expiring activations checked 

out of an activation server on the network, and do not require a 

continuous network connection. 

For standard installations of the product software, FactoryTalk View SE 

supports only the use of both types of shared concurrent activations. 

Node-locked activations are not supported. 

Tip: To learn about the types of activation that other Rockwell 
Automation products can use, see the product 
documentation or contact your local Rockwell 
Automation Sales office. 

 

If the FactoryTalk View components you have installed cannot be activated, 

for example, because the activation server is unavailable or because 

borrowed activations have expired, the software will continue to run for up 

to seven days. 

About FactoryTalk 
Activation Manager 

What happens if 
FactoryTalk View is 
not activated? 
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The seven-day grace period allows time to correct the problem with 

acquiring activations without disrupting critical applications. If activation is 

restored within seven days, normal operations will resume. 

If activation is not restored, the grace period will expire. After the grace 

period expires, if you restart FactoryTalk View SE and activation remains 

unavailable, the software will run for two hours in demo mode. 

With a FactoryTalk View SE network distributed application, running in 

demo mode, you can: 

 Create or load up to five HMI servers locally in FactoryTalk View 

Studio. 

 Create or load up to five graphic displays per HMI server. 

 Run a local station FactoryTalk View application for up to two hours. 

In demo mode, remote clients cannot connect to a FactoryTalk View 

server. 

 In Symbol Factory, import only the first graphic in each category. 

Floating concurrent activations are assigned automatically to clients that 

need them, and returned automatically to the activation server pool when 

FactoryTalk View SE stops running on the client, or when the client 

computer shuts down. 

Client computers must be set up to obtain floating activations from the 

activation server. 

If you prefer to use borrowed activations for clients, skip to Borrow 

activations for development computers on page 59. 

After you set up the activation server (or servers), you can specify which 

server each client computer will obtain activations from. 

Once a client is connected to a server, all you have to do is to run the 

FactoryTalk View software (for example, the FactoryTalk View SE Client), 

and the server will issue available activations automatically. 

A continuous network connection is required for an activation client to use 

floating activations. After a client obtains a floating activation, when the 

activation server detects that the client has been disconnected, the activation 

is returned to the server pool. 

To ensure that critical software components (redundant HMI servers, for 

example) can always obtain the necessary activations, set up an activation 

server on the computer where the software is running. 

Set up client 
computers to obtain 
floating activations 
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To ensure that critical software components in a network application using 

floating activations can always obtain the necessary activations, even if the 

network is disrupted, set up a FactoryTalk Activation server on every 

computer where the FactoryTalk View SE software is running. This includes 

all clients and all servers, whether redundant or not. 

For example, to ensure that a redundant FactoryTalk View SE Server 

remains activated, install the activation server on both computers hosting the 

redundant server pair, and then add the necessary activations to those 

computers. 

If it is not convenient for a development computer to remain connected to the 

network where the activation server resides, you can connect to the 

activation server temporarily, borrow a concurrent activation for a limited 

amount of time, and then disconnect. When the time-limited activation 

expires, its associated software is no longer activated, and the activation 

automatically becomes available again from the server's activation pool. 

Only the FactoryTalk View Studio activation keys can be borrowed. While 

developing Network applications disconnected from the network, the 

FactoryTalk View Studio activation key is shared by any test clients and 

HMI servers in your application, allowing all necessary components to run 

for development purposes. 

Note: To use borrowed activations, you must upgrade to 

FactoryTalk Activation Manager version 3.30 or later (included 
on any FactoryTalk CPR 9 SR 4 product’s DVD) on all server 
and client computers where the borrowed activations will be 
used. 

 

The activation files you download from the Rockwell Software Activation 

Website contain the activation keys you purchased, in encrypted form. The 

activation key is the software that activates FactoryTalk View SE 

components. Following is a list of activation keys used by the FactoryTalk 

View SE and ME products. 

Tip: For information about the keys required to activate other 
Rockwell Automation products in your application, see 
the product documentation. 

 

To activate this software product or component Use this key 

FactoryTalk View Studio* 

*Includes software for developing and testing FactoryTalk View Site Edition and 
Machine Edition applications 

RSV.STUDIO 

FactoryTalk View SE Server (network distributed applications), unlimited displays RSVSESRV.MAX 

FactoryTalk View SE Server (network distributed applications), 250 displays RSVSESRV.250 

Ensure that network 
application 
components stay 
activated 

Borrow activations 
for development 
computers 

Activation keys for 
FactoryTalk View 
software 
components 
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FactoryTalk View SE Server (network distributed applications), 100 displays RSVSESRV.100 

FactoryTalk View SE Server (network distributed applications), 25 displays RSVSESRV.25 

FactoryTalk View SE Client (network distributed applications), read and write RSVSECLI.RW 

FactoryTalk View SE Client (network distributed applications), view only RSVSECLI.RO 

FactoryTalk View SE Station (network station and local station applications), 
unlimited displays 

RSVSE.MAX 

FactoryTalk View SE Station (network station and local station applications), 250 
displays 

RSVSE.250 

FactoryTalk View SE Station (network station and local station applications), 100 
displays 

RSVSE.100 

FactoryTalk View SE Station (network station and local station applications), 25 
displays 

RSVSE.25 

FactoryTalk View SE Station (network station and local station applications), 15 
displays 

RSVSE.15 

 

Sharing keys among multiple software 
components 

Multiple FactoryTalk View SE software components can function using one 

activation key in the following cases: 

 Multiple instances of FactoryTalk View Studio or the FactoryTalk 

View SE Client running on the same computer can use a single key 

(RSV.STUDIO or RSVSECLI), as long as the components are not 

running in a Terminal Services session. 

 In the network application of FactoryTalk View SE versions earlier 

than 6.10, for development and testing purposes, one FactoryTalk 

View Studio key activates a FactoryTalk View SE Client and 

SE Server on the same computer. Remote clients and servers require 

component-specific activations. 

Note: In version 6.10 or higher, one FactoryTalk Studio key can no 
longer activate the local server or client to run in test run 
mode. 

 Local applications use a single key (RSVSE.*) to activate both the 

FactoryTalk View SE Client and the FactoryTalk View SE Server at 

run time. These components running together are also known as 

FactoryTalk View SE Station. 

Tip: FactoryTalk View SE Server activations—known as 
capacity activations because they are based on the 
number of displays in an application—cannot be shared. 
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Read-write versus view-only activations 

In a network application, FactoryTalk View SE Clients can use two types of 

activation: 

 Read-write keys (RSVSECLI.RW) allow full read-write privileges. 

 View-only keys (RSVSECLI.RO) allow view-only privileges. 

Whether a FactoryTalk View SE Client runs in read-write or in view-only 

mode depends on the type of activation key available for the client to use, 

and whether the client itself is set up as read-write or view-only: 

 If the activation server can only provide view-only licenses, and a 

read-write client obtains one of these licenses, then the activation 

overrides the client’s configuration, and the client runs in view-only 

mode. 

 If the activation server can only provide read-write licenses, and a 

view-only client obtains one of these licenses, then the client’s 

configuration overrides the activation, and the client runs in view-only 

mode. 

 Do not rely on available activation keys to determine whether the 

FactoryTalk View SE Client runs in read-write or view-only mode. 

Instead, to ensure that a client always runs in view-only mode, choose 

the view-only option when setting up the client’s configuration file. 

For details, click Help in the FactoryTalk View SE Client wizard. 

 





 

 Rockwell Automation Publication VIEWSE-IN003N-EN-E 63 

Chapter 6 

Deploying network distributed 

applications 

After developing and testing a FactoryTalk View Site Edition network 

distributed application, you can deploy it to run in a live setting, such as the 

plant floor. Deploying a network distributed application often involves 

installing FactoryTalk View SE software components on multiple client and 

server computers.  

For details about installing the software, see Installing FactoryTalk View on 

page 37. For information about upgrading a network distributed application 

that is already deployed, see Upgrading an operating FactoryTalk View SE 

application on page 99. 

For details about the structure and content of network distributed 

applications, see Chapter 6, Working with network distributed applications in 

the FactoryTalk View Site Edition User’s Guide. 

The checklist in this section summarizes the basic tasks involved in 

deploying a FactoryTalk View SE network distributed application. Each task 

is described in detail in the rest of this chapter. Add or remove steps as 

necessary to create a customized procedure that reflects the design and 

content of your FactoryTalk View application. For example, your application 

might include additional communications or database servers. 

For details about deploying FactoryTalk Alarms and Events servers, see the 

FactoryTalk Alarms and Events Configuration Guide by selecting Start > 

All Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk 

Alarms and Events Configuration Guide. 

Task checklist 

 Back up the network distributed application on page 64. 

 Restore the network distributed application on page 65. 

 Renew data server shortcuts, topics, and device paths on page 68. 

 Set up additional HMI server properties on page 69. 

 Set up the FactoryTalk View SE Clients on page 73. 

 Run the FactoryTalk View SE Clients on page 75 to test the 

application. 

Overview of tasks 
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Use the Distributed Application Manager tool to back up a FactoryTalk 

View SE network distributed application. The archive includes all 

FactoryTalk Directory like accounts, passwords, policies and security 

settings. It also includes all application contents like application 

configurations, HMI servers, data servers, and tag Alarm and Event servers. 

Tip:  RSLinx Classic configuration files are not included 
when you back up an application. You need to back up 
the configuration files before upgrading. For 
instructions, see Back up and restore RSLinx Classic 
configurations on page 67. 

 For information about backing up and restoring files 
that belong to FactoryTalk Tag Alarm and Event 
Servers, see the FactoryTalk Alarms and Events Help. 

Before backing up an application, record the user names and passwords of 

administrative users set up for the application, in case you need this 

information after restoring the application. 

To back up the application: 

1. On the HMI server, select Start > All Programs > Rockwell 

Software > FactoryTalk View > Tools > Distributed Application 

Manager. 

Tip: The logged on user must have the Backup and restore 
directory contents permission. For more information, 
see FactoryTalk Security Help. 

2. In the Create a Backup tab, select your application and follow the 

wizard. The following example shows an overview of the tool when 

creating a backup. For more instructions, see Distributed Application 

Manager Help. 

 

Back up the 
network distributed 
application 
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About backing up System information with an 
application 

The following illustration shows what a FactoryTalk View SE network 

distributed application looks like when opened in FactoryTalk View Studio. 

 

The FactoryTalk Network Directory (also called the Network Directory) is 

represented at the top of application hierarchy. One level down, the System 

folder stores settings that are used by all the applications that belong to the 

same Network Directory. 

For example, FactoryTalk user and computer accounts set up for each 

application are stored in the System folder. 

Note: RSLinx Enterprise device paths are also saved with System 
information, and might not be correct for the computer where 
the application will be restored. For information about checking 
device paths after restoring an application. see Verify RSLinx 
Enterprise shortcuts on page 116. 

 

Before restoring the network distributed application, all client and server 

computers in the application must point to the same FactoryTalk Directory 

server.  

You can restore the application to an existing or a new FactoryTalk 

Directory. You can choose to restore the HMI project files only, the 

application only, the application with FactoryTalk Directory, or the 

application with FactoryTalk Directory and security identifier. 

Restore the network 
distributed 
application 
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Note: Restoring archived application with FactoryTalk Directory 
System information replaces existing FactoryTalk Directory 
System settings on the computer. When deploying a 
FactoryTalk View SE network distributed application, it is 
recommended that you do not restore FactoryTalk Directory 
System information with the application, as this will remove 
existing computer accounts and prevent users from logging on 
to the Network Directory. 

Include FactoryTalk Directory System information in the 
restore operation only if there are no applications using the 
current Network Directory, or if the effect on existing 
applications will be minimal. 

During the restore operation, you can also: 

 Specify HMI server host computer names. 

 Specify data server host computer names. 

 Specify tag alarm and event server host computer names. 

 Restore both the primary and secondary servers at the same time when 

restoring an archive with redundant servers. 

To restore an application: 

1. On the HMI server, select Start > All Programs > Rockwell 

Software > FactoryTalk View > Tools > Distributed Application 

Manager. 

Tip: The logged on user must have the Backup and restore 
directory contents permission. For more information, 
see FactoryTalk Security Help. 

2. In the Restore an Archive tab, specify the restore options. 
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3. Follow the wizard to restore the application. The following example 

shows an overview of the tool when restoring an archive. For more 

instructions, see Distributed Application Manager Help. 

 

Restore RSLinx Enterprise configurations 

When you back up a FactoryTalk View SE network distributed application, 

the archive includes RSLinx Enterprise shortcut names, but does not include 

device path information. 

After restoring the application, you must open the Communications Setup 

editor in FactoryTalk View Studio, and re-apply the device path for each 

configured shortcut. 

For details, see Renew data server shortcuts, topics, and device paths on page 

68. 

Back up and restore RSLinx Classic configurations 

RSLinx Classic configuration files are not included when you back up an 

application. You have to back up, move, and restore the files manually. 

If RSLinx Classic is installed on the development and production computers, 

you can use the RSLinx Classic Backup/Restore tool to back up and restore 

configuration files. 
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Tip: You can also restore RSLinx Classic configuration files 
from the Wizard Completed window of the RSLinx 
Classic software setup program. 

To move RSLinx Classic configuration files: 

1. On the development computer, click Start > All Programs > 

Rockwell Software > RSLinx, and then click RSLinx Classic 

Backup Restore Utility.  

2. In the RSLinx Classic Backup/Restore tool, click Backup. 

 

3. Select a folder for the backup file, type a file name, and then click 

Save. 

4. In Windows Explorer, copy the backup file (with .rsx extension), and 

then paste it into a location on the data server production computer. 

5. On the production computer, click Start > All Programs > Rockwell 

Software > RSLinx, and then click RSLinx Classic Backup Restore 

Utility. 

6. In the RSLinx Backup/Restore tool, click Restore. 

7. Find and select the backup file you just pasted, and then click Open. 

After restoring RSLinx data servers in the application, renew or verify the 

topics, shortcuts, and device paths associated with each data server, as 

needed. 

If you are restoring redundant data servers, then the device paths must be 

confirmed and reapplied for both the primary and the secondary server. 

To renew RSLinx Enterprise device paths: 

1. Open the restored application in the FactoryTalk Administration 

Console. 

2. In the Explorer window, expand the data server (RSLinx Enterprise), 

and then double-click Communications Setup. 

Renew data server 
shortcuts, topics, 
and device paths 
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3. In the Communications Setup editor, select each configured RSLinx 

Enterprise shortcut, point the shortcut at the correct device, and then 

click Apply. 

4. Save the configuration, and then close the Communications Setup 

editor. 

To verify RSLinx Classic topics: 

1. On the data server computer, select Start > All Programs > Rockwell 

Software > RSLinx > RSLinx Classic. 

2. On the DDE/OPC menu, click Topic Configuration. 

3. In the Topic List, select each configured topic and confirm that the 

corresponding data source updates correctly. 

4. Click the Advanced Communication tab, confirm that there is a 

device path specified for Remote Addressing, and then click Done. 

After restoring the application, you can open the HMI server properties 

dialog box in FactoryTalk View Studio to verify the HMI server settings and 

set up the following HMI server properties, as needed. 

 In the General tab, to determine when the HMI server will load, select 

a Startup Type. 

Set up additional 
HMI server 
properties 
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You can specify that the HMI server will load when the first client 

attempts to connect to it (On demand) or when the host computer starts 

up (Load and run startup components when operating system 

initializes). The second option is recommended for production HMI 

servers, and required for an HMI server that is part of a redundant pair. 
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 In the Redundancy tab, to set up redundancy for the HMI server, first 

select the check box, Provide redundancy using a secondary server; 

then, specify the name the computer that will host the secondary 

server, and select a switchover option. 

 

Tip: Before you can specify the secondary server in a 
redundant pair, you must manually copy the HMI project 
files to the secondary server computer. 

 In the Components tab, select the application components that will 

start automatically when the HMI server starts, and select the macro 

that will run when the server shuts down. You can also start or stop 

components manually. 
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If the HMI server is redundant, you can also start and stop components 

for the primary and the secondary server, and select On active and On 

standby macros. 

 

You must set up the HMI server properties separately, for each server in the 

FactoryTalk View SE network distributed application you are deploying. 

You can do this on the computer running the HMI server, or from a remote 

computer. 

For details about setting up HMI server properties, see Chapter 6, Working 

with network distributed applications in the FactoryTalk View Site Edition 

User’s Guide. For details about setting up redundant HMI servers, see 

Chapter 14, Setting up FactoryTalk system availability in the FactoryTalk 

View Site Edition User’s Guide. 

Synchronize redundant HMI servers and projects 

After setting up redundancy for an HMI server, to ensure that identical copies 

of the HMI server and project files are running on the primary and the 

secondary computers, replicate changes from the primary to the secondary 

server. 
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The replicate operation copies the primary server’s configuration files, 

including settings in the Components tab, to the secondary server. 

For example, if an On Active and a Shutdown macro are selected for the 

primary server, the settings will be replicated to the secondary. This means 

that the same macros specified for the primary server will run when the 

secondary server becomes active or shuts down. 

Information that is not included in the replicate operation includes datalog 

files generated at run time, the current value of HMI memory tags, retentive 

tags, and the HMI tag alarm suppressed list. 

Note: For the replicate operation to succeed, a copy of the HMI 
project files must already exist on the secondary server 
computer. In addition, the state of the primary server must be 
Active, and the state of the secondary server must be 
Standby, for the duration of the operation. 

To replicate changes from the primary to the secondary server: 

1. Open the restored application in the FactoryTalk View Studio 

Enterprise. 

2. In the Explorer window, right-click the HMI server’s name, and then 

click Properties. 

3. Click the Redundancy tab, and then click Replicate Primary to 

Secondary. 

Tip: If a secondary server is not specified, the Replicate 
Primary to Secondary button will not be available in the 
Redundancy tab. 

To finish replicating, follow the on-screen instructions. After the 

replicate operation is complete, the secondary server is restarted. 

The FactoryTalk View SE Client provides a complete and secure run-time 

environment for a local application. For example, operators can use the client 

to: 

 Load, view, and interact with graphic displays from any HMI server in 

the application. 

 Monitor and control alarms (HMI tag alarms and FactoryTalk Alarms 

and Events). 

 View and interact with trends. 

 Adjust set points. 

 Start and stop server components. 

Set up FactoryTalk 
View SE Clients 
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In a network distributed application, FactoryTalk View SE Clients, HMI 

servers, and data servers can run on multiple computers, connected over a 

network. 

If you have already set up FactoryTalk View SE Client files for a network 

distributed application, you can copy the files to the production computers. 

Otherwise, you can create new client files. 

Create a new FactoryTalk View SE Client file 

FactoryTalk View SE Client configuration files specify the name of the 

application the client will connect to, the components that start when the 

connection is made, and how the client will behave at run time. 

To create a new client file, use the FactoryTalk View SE Client Wizard. You 

can also use the wizard to modify or run an existing client file, or to remove a 

client from the list of available files. 

Tip: It is not necessary to start the HMI server if you want to 
use the FactoryTalk View SE Client Wizard. 

To create a new FactoryTalk View SE Client file: 

1. On the desktop, select Start > All Programs > Rockwell Software > 

FactoryTalk View > FactoryTalk View Site Edition Client. 

2. In the FactoryTalk View SE Client Wizard, click New, and then follow 

the on-screen instructions. For details about options in the wizard, click 

Help. 

The client file is created with a .cli extension, in the location you 

specified. 

Copy existing FactoryTalk View SE Client files 

When setting up the FactoryTalk View SE Clients for a network distributed 

application, you can copy existing client files from the development 

computer to the client production computers. 

You can run the client configuration from the desktop, or from any other 

location on the client computer. 

By default, client configuration files are saved under C:\Users\Public\Public 

Documents\RSView Enterprise\SE\Client. 



 Deploying network distributed applications                  Chapter 6 

 

 Rockwell Automation Publication VIEWSE-IN003N-EN-E 75 

Lock operators into the run-time environment 

To lock operators into the FactoryTalk View SE Client at run time, for 

example, to prevent access to other programs on the computer, try one or 

more of the following methods: 

 Limit the ability to manipulate graphic displays, by removing the 

title bar or minimize and maximize buttons from selected displays. 

To do this, in the Display Settings dialog box, clear the check boxes 

Title Bar, Minimize Button, and Maximize Button. For details, see 

Chapter 16, Creating graphic displays in the FactoryTalk View Site 

Edition User’s Guide. 

 Limit the ability to manipulate the client window, by removing the 

title bar or minimize and maximize buttons from the client. 

To do this, in the FactoryTalk View SE Client wizard, clear the check 

boxes, Show title bar, and Show system menu and close button. For 

details, click Help in the FactoryTalk View SE Client wizard. 

 Prevent switching to other applications. To do this, in the 

FactoryTalk View SE Client wizard, select the check box, Disable 

switch to other applications. For details, click Help in the 

FactoryTalk View SE Client wizard. 

 Restrict access to the desktop, using the DeskLock tool.   

To open Desklock, on the desktop click Start > All Programs > 

Rockwell Software > FactoryTalk View > Tools, and then click 

DeskLock.  

For details about using DeskLock, click Help within the tool. 

Note: Do not enable DeskLock until you read the help for the tool 
and understand how it works. Otherwise, you could end up 
locking yourself out of the desktop. 

 

Once the network distributed application is fully deployed, test it by running 

the FactoryTalk View SE Clients. 

Note: To connect a FactoryTalk View SE Client to a network 
distributed application, all client and server computers in the 
application must point at the same FactoryTalk Network 
Directory server. For details, see Specify the Network 
Directory location on application computers on page 79. 

For tips to help you get communications working between clients and 

servers, see the FactoryTalk View Site Edition Help. 

Run the FactoryTalk 
View SE Clients 
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To run an SE Client using the .cli file: 

Double-click the client setup file (.cli), in the default folder 

C:\Users\Public\Public Documents\RSView Enterprise\SE\Client. 

To run an SE Client from FactoryTalk View Studio: 

1. In FactoryTalk View Studio, on the Tools menu, click Launch SE 

Client. 

2. In the FactoryTalk View SE Client Wizard dialog box, select the 

client configuration file from the list of most recently used files and 

click Run. To search for and select another file, click the browse 

button. 

To run an SE Client when Windows starts: 

1. Create a shortcut to the.cli file (on the desktop, for example). 

2. Move the shortcut to the Windows Startup folder. 

For information about adding shortcuts to the Startup folder, see the 

Windows Help 

Log on to the FactoryTalk View SE Client 

To start the FactoryTalk View SE Client, or to change users while the client 

is running, the user logging on must have the necessary security permissions. 

If the user does not have the necessary permissions, the FactoryTalk View 

SE Client login dialog box opens, to let another user log on. 
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Chapter 7 

Deploying network station 

applications 

After you finish developing and testing a FactoryTalk View Site Edition 

network station application, you can deploy it to run in a live setting, such as 

the plant floor. Deploying a network station application involves installing all 

FactoryTalk View SE software components on the application’s host 

computer.   

For details about installing the software, see Installing FactoryTalk View on 

page 37. 

For details about the structure and content of network station applications, 

see Chapter 7, Working with network station applications in the FactoryTalk 

View Site Edition User’s Guide. 

The checklist in this section summarizes the basic tasks involved in 

deploying a FactoryTalk View SE network station application. Use the 

checklist to guide you through the tasks you need to perform. Each task is 

described in detail in the rest of this chapter. 

If appropriate, add or remove details to create a customized procedure that 

reflects the design and content of your FactoryTalk View application. For 

example, your application might include additional communications or 

database servers so you may need to repeat these steps accordingly. 

Tip: If your application includes Tag Alarm and Event 
Servers, see the FactoryTalk Alarms and Events Help for 
information about deploying these servers. 

 

Task checklist 

 Move the network station application on page 78 

 Specify the Network Directory location on application computers on 

page 79 if necessary 

 Move the application’s data server files on page 79 

 Specify data server host computer names on page 81 

 Renew data server shortcuts, topics, and device paths on page 68 

Overview of tasks 
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 Specify when HMI server components start or stop on page 83 

 Set up the FactoryTalk View SE Client on page 84 

 Run the FactoryTalk View SE Client on page 86 to test the application 

There are two steps involved in moving a network station application: on the 

development computer, back up the application; then, on the production 

computer, restore the application archive. 

You can perform both of these steps in the Application Manager tool. For 

details about options in the Application Manager, click Help in the tool. 

Note: Before backing up an application, record the user names and 
passwords of administrative users set up for the application, in 
case you need this information after restoring the application. 

To back up a network station application: 

1. On the desktop, select Start > All Programs > Rockwell Software > 

FactoryTalk View > Tools > Application Manager.  

2. In the Application Manager, select Site Edition (Network Station), 

and then click Next. 

Tip: To back up a network station application, the logged on 
user must have FactoryTalk administrative rights. If you 
receive a prompt to log on, check with your System 
Administrator. 

3. Select the back up operation, and then follow the instructions in the 

Application Manager to complete the operation. 

4. Copy the .apa file to the new (production) computer. 

If you are restoring a network station application on a computer that contains 

a copy of the original application, ensure the application is not running, then 

use the Application Manager to delete (or rename) the original application, 

before you begin the restore operation. 

To restore a network station application: 

1. On the production computer, on the desktop, select Start > All 

Programs > Rockwell Software > FactoryTalk View > Tools > 

Application Manager.  

2. Select Site Edition (Network Station), and then click Next. 

Move the network 
station application 
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Tip: To restore a network station application, the logged on 
user must have FactoryTalk administrative rights. If you 
receive a prompt to log on, check with your System 
Administrator. 

3. Select the restore operation, and then follow the instructions in the 

Application Manager to complete the operation. 

4. Copy the backed up application to the new (production) computer. 

If you have not done so already, use the FactoryTalk Directory Server 

Location Utility to specify the location of the FactoryTalk Network 

Directory server. 

Performing this task might require more than one set of FactoryTalk security 

credentials: 

 To use the FactoryTalk Directory Server Location Utility, you must 

have administrative rights on the local computer. 

 To specify a remote location for the Network Directory, you must have 

administrative rights on the remote computer. 

To specify the Network Directory on application computers: 

1. On the client or server computer, select Start > All Programs > 

Rockwell Software > FactoryTalk Tools > Specify FactoryTalk 

Directory Location. 

2. Click the Browse button beside the field, Computer hosting directory 

server. 

3. In the FactoryTalk Directory Server Configuration dialog box, click 

Remote computer. 

4. Type the name of the Network Directory server computer, or click the 

Browse button to find and select the computer, and then click OK. 

You will have to log on as an administrator on the remote computer. 

5. Click OK again, to close the FactoryTalk Directory Server Location 

Utility. 

After specifying the FactoryTalk Network Directory location on application 

computers, ensure that the required communications software (RSLinx 

Enterprise, RSLinx Classic, or other OPC software) is installed on computers 

that will run data servers. 

Then, if necessary for the data servers you are deploying, move configuration 

files to the production computers, and then specify the new host computer 

names. 

Specify the Network 
Directory location 
on application 
computers 

Move the 
application’s data 
server files 
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Tip: For information about moving setup files for OPC data 
servers other than RSLinx Classic, see the product 
documentation for the OPC server 

 

Back up and restore RSLinx Classic configurations 

RSLinx Classic configuration files are not included when you back up an 

application. You have to back up, move, and restore the files manually. 

If RSLinx Classic is installed on the development and production computers, 

you can use the RSLinx Classic Backup/Restore tool to back up and restore 

configuration files. 

Tip: You can also restore RSLinx Classic configuration files 
from the Wizard Completed window of the RSLinx 
Classic software setup program. 

To move RSLinx Classic configuration files: 

1. On the development computer, click Start > All Programs > 

Rockwell Software > RSLinx, and then click RSLinx Classic 

Backup Restore Utility.  

2. In the RSLinx Classic Backup/Restore tool, click Backup. 

 

3. Select a folder for the backup file, type a file name, and then click 

Save. 

4. In Windows Explorer, copy the backup file (with .rsx extension), and 

then paste it into a location on the data server production computer. 

5. On the production computer, click Start > All Programs > Rockwell 

Software > RSLinx, and then click RSLinx Classic Backup Restore 

Utility. 

6. In the RSLinx Backup/Restore tool, click Restore. 

7. Find and select the backup file you just pasted, and then click Open. 
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After moving data server configuration files to production computers, open 

the restored network station application, and in the Properties dialog box for 

each data server, specify the name of the server’s host computer. 

Then, renew RSLinx shortcuts, topics, and device paths, as needed. For 

details, see Renew data server shortcuts, topics, and device paths on page 68. 

For information about setting up other data server properties, click Help in 

the server’s Properties dialog box, or see the product documentation. 

Tip: The first time you open an application after relocating a 
data server, if the server does not load, you should still 
be able to open the Properties dialog box and change 
the host computer name. After the computer name is 
updated, the server should load as expected. 

To change the RSLinx Enterprise server computer name: 

1. Click Start > All Programs > Rockwell Software, and then click 

FactoryTalk Administration Console. 

2. In the Select FactoryTalk Directory dialog box, select Network, and 

then click OK. 

Specify data server 
host computer 
names 
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3. In the Explorer window, expand the name of the restored application, 

right-click the RSLinx Enterprise server’s name, and then click 

Properties. 

 

4. In the General tab, in the field, Computer hosting the RSLinx 

Enterprise server, type the name of the production computer, or click 

Browse to find and select the computer, and then click OK. 

Acknowledge the warning if needed by clicking OK. 

To change the RSLinx Classic server computer name: 

1. Open the restored application in the FactoryTalk Administration 

Console. To learn how to do this, see the previous task. 

2. In the Explorer window, expand the name of the restored application, 

right-click the RSLinx Classic server’s name, and then click 

Properties. 

3. In the General tab, in the field, Computer that will run the OPC 

server, type the name of the production computer, or click Browse to 

find and select the computer, and then click OK. 
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After restoring RSLinx data servers in the application, renew or verify the 

topics, shortcuts, and device paths associated with each data server, as 

needed. 

If you are restoring redundant data servers, then the device paths must be 

confirmed and reapplied for both the primary and the secondary server. 

To renew RSLinx Enterprise device paths: 

1. Open the restored application in the FactoryTalk Administration 

Console. 

2. In the Explorer window, expand the data server (RSLinx Enterprise), 

and then double-click Communications Setup. 

3. In the Communications Setup editor, select each configured RSLinx 

Enterprise shortcut, point the shortcut at the correct device, and then 

click Apply. 

4. Save the configuration, and then close the Communications Setup 

editor. 

To verify RSLinx Classic topics: 

1. On the data server computer, select Start > All Programs > Rockwell 

Software > RSLinx > RSLinx Classic. 

2. On the DDE/OPC menu, click Topic Configuration. 

3. In the Topic List, select each configured topic and confirm that the 

corresponding data source updates correctly. 

4. Click the Advanced Communication tab, confirm that there is a 

device path specified for Remote Addressing, and then click Done. 

In FactoryTalk View Studio, open the Properties dialog box for the HMI 

server in the application, to view the location of the HMI project files, the 

current number of displays in the application, and the maximum number of 

displays allowed. 

You can add a description for the HMI server and, in the Components tab, 

select components that will start when the HMI server starts running. 

Tip: In a local station application, the HMI server and the 
application have the same name. The name cannot be 
modified in the HMI server's Properties dialog box. 

To open the HMI Server Properties dialog box: 

1. Click Start > All Programs > Rockwell Software, and then click 

FactoryTalk View Studio. 

Renew data server 
shortcuts, topics, 
and device paths 

Specify when HMI 
server components 
start or stop 
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2. Select View Site Edition (Network Station), and then click Continue. 

3. Click the Existing tab, select the network station application’s name, 

and then click Open. 

4. In the Explorer window, right-click the HMI server’s name, and then 

click Properties. 

How HMI server components start and stop 

Use the HMI Server Properties dialog box to specify which components in a 

local station application will start automatically, when the HMI server starts 

running. 

In a network station or local station application, the HMI server loads and the 

specified components start running when the FactoryTalk View SE Client 

connects to the application. When the client stops running, the HMI server is 

unloaded, and the specified shutdown macro is run. 

You can also start or stop the HMI server components manually. To do this, 

in the Components tab, click Run Startup Components and Stop All 

Running Components, respectively. 

To select HMI server startup and shutdown components: 

1. In the HMI Server Properties dialog box, click the Components tab. 

2. To specify startup components, select the component check boxes, and 

then select the components you want to start automatically, when the 

HMI server starts running. 

3. To specify a shutdown macro, select the check box On shutdown 

macro, and then select the macro you want to run when the HMI 

server stops running. 

The FactoryTalk View SE Client provides a complete and secure run-time 

environment for a network station or local station application. For example, 

operators can use the client to: 

 Load, view, and interact with multiple graphic displays from the HMI 

server. 

 Manage alarm information. 

 View trends. 

 Adjust set points. 

 Start and stop server components. 

Set up the 
FactoryTalk View 
SE Client 
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To run a network station or local station application, the FactoryTalk View 

SE Client must run on the same computer as the HMI server. 

If you have already set up a FactoryTalk View SE Client file for the 

application, you can copy the file to the production computer. Otherwise, you 

can create a new client file. 

Create a new FactoryTalk View SE Client file 

FactoryTalk View SE Client configuration files specify the name of the 

application the client will connect to, the components that start when the 

connection is made, and how the client will behave at run time. 

To create a new client file, use the FactoryTalk View SE Client Wizard. You 

can also use the wizard to modify or run an existing client file, or to remove a 

client from the list of available files. 

Tip: It is not necessary to start the HMI server if you want to 
use the FactoryTalk View SE Client Wizard. 

To create a new FactoryTalk View SE Client file: 

1. On the desktop, select Start > All Programs > Rockwell Software > 

FactoryTalk View > FactoryTalk View Site Edition Client. 

2. In the FactoryTalk View SE Client Wizard, click New, and then follow 

the on-screen instructions. For details about options in the wizard, click 

Help. 

The client file is created with a .cli extension, in the location you 

specified. 

Lock operators into the run-time environment 

To lock operators into the FactoryTalk View SE Client at run time, for 

example, to prevent access to other programs on the computer, try one or 

more of the following methods: 

 Limit the ability to manipulate graphic displays, by removing the 

title bar or minimize and maximize buttons from selected displays. 

To do this, in the Display Settings dialog box, clear the check boxes 

Title Bar, Minimize Button, and Maximize Button. For details, see 

Chapter 16, Creating graphic displays in the FactoryTalk View Site 

Edition User’s Guide. 

 Limit the ability to manipulate the client window, by removing the 

title bar or minimize and maximize buttons from the client. 



Chapter 7                  Deploying network station applications 

 

86 Rockwell Automation Publication VIEWSE-IN003N-EN-E 

To do this, in the FactoryTalk View SE Client wizard, clear the check 

boxes, Show title bar, and Show system menu and close button. For 

details, click Help in the FactoryTalk View SE Client wizard. 

 Prevent switching to other applications. To do this, in the 

FactoryTalk View SE Client wizard, select the check box, Disable 

switch to other applications. For details, click Help in the 

FactoryTalk View SE Client wizard. 

 Restrict access to the desktop, using the DeskLock tool.   

To open Desklock, on the desktop click Start > All Programs > 

Rockwell Software > FactoryTalk View > Tools, and then click 

DeskLock.  

For details about using DeskLock, click Help within the tool. 

Note: Do not enable DeskLock until you read the help for the tool 
and understand how it works. Otherwise, you could end up 
locking yourself out of the desktop. 

 

Once the application is deployed, test it by running the FactoryTalk View 

SE Client. 

To run an SE Client using the .cli file: 

Double-click the client setup file (.cli), in the default folder 

C:\Users\Public\Public Documents\RSView Enterprise\SE\Client. 

To run an SE Client from FactoryTalk View Studio: 

1. In FactoryTalk View Studio, on the Tools menu, click Launch SE 

Client. 

2. In the FactoryTalk View SE Client Wizard dialog box, select the 

client configuration file from the list of most recently used files and 

click Run. To search for and select another file, click the browse 

button. 

To run an SE Client when Windows starts: 

1. Create a shortcut to the.cli file (on the desktop, for example). 

2. Move the shortcut to the Windows Startup folder. 

For information about adding shortcuts to the Startup folder, see the 

Windows Help 

Run the FactoryTalk 
View SE Client 
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Log on to the FactoryTalk View SE Client 

To start the FactoryTalk View SE Client, or to change users while the client 

is running, the user logging on must have the necessary security permissions. 

If the user does not have the necessary permissions, the FactoryTalk View 

SE Client login dialog box opens, to let another user log on. 

 

To make minor changes to an application after it is deployed, use either 

FactoryTalk View Studio or the FactoryTalk View SE Administration 

Console. The SE Administration Console contains the following subset of 

editors. 

To do this in the SE Administration Console Use this editor 

Change the properties of an HMI server. HMI Server Properties 

Change the properties of a data server. Data Server Properties 

Add FactoryTalk users to an application. Runtime Security 

Set up security for commands and macros. Secured Commands 

Run FactoryTalk View commands. Command Line 

Change how HMI tag alarms are logged. Alarm Setup 

Change the paths of data log models. Data Log Paths 

Manage HMI tag alarm log files. Alarm Log Setup 

Import and export HMI tags. Tag Import and Export Wizard 

For details about options in these editors, click Help. 

To open a network station application in FactoryTalk View Studio: 

1. Select Start > All Programs > Rockwell Software > FactoryTalk 

View > FactoryTalk View Studio. 

2. Select View Site Edition (Network Station), and then click Continue. 

3. In the Existing tab, select the restored application’s name, and then 

click Open. 

 

Administer 
deployed 
applications 
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Chapter 8 

Deploying local station applications 

After you finish developing and testing a FactoryTalk View Site Edition 

local station application, you can deploy it to run in a live setting, such as the 

plant floor. Deploying a local station application involves installing all 

FactoryTalk View SE software components on the application’s host 

computer. 

For details about installing the software, see Installing FactoryTalk View on 

page 37. 

For details about the structure and content of local station applications, see 

Chapter 8, Working with local station applications in the FactoryTalk View 

Site Edition User’s Guide. 

The checklist in this section summarizes the basic tasks involved in 

deploying a FactoryTalk View SE local station application. Use the checklist 

to guide you through the tasks you need to perform. Each task is described in 

detail in the rest of this chapter. 

If appropriate, add or remove details to create a customized procedure that 

reflects the design and content of your FactoryTalk View application. For 

example, your application might include additional communications or 

database servers. 

Tip: If your application includes Tag Alarm and Event 
Servers, see the FactoryTalk Alarms and Events Help for 
information about deploying these servers. 

 

Task checklist 

 Move the local station application on page 90 

 Move data servers and change their properties on page 91 

 Specify OPC data server host computer names on page 93 

 Specify when HMI server components start or stop on page 83 

 Set up the FactoryTalk View SE Client on page 84 

 Run the FactoryTalk View SE Client on page 86 to test the application 

Overview of tasks 
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There are two steps involved in moving a local station application: on the 

development computer, back up the application; then, on the production 

computer, restore the application archive. 

You can perform both of these steps in the Application Manager tool. For 

details about options in the Application Manager, click Help in the tool. 

Note: Before backing up an application, record the user names and 
passwords of administrative users set up for the application, in 
case you need this information after restoring the application. 

To back up a local station application: 

1. On the desktop, click Start > All Programs > Rockwell Software > 

FactoryTalk View > Tools, and then click Application Manager.  

2. In the Application Manager, select Site Edition (Local Station), and 

then click Next. 

Tip: The logged on user must have FactoryTalk 
administrative rights. If you receive a prompt to log on, 
check with your System Administrator. 

3. Select the back up operation, and then follow the instructions in the 

Application Manager to complete the operation. 

4. Copy the .apa file to the new (production) computer. 

If you are restoring a local station application on a computer that contains a 

copy of the original application, restart the computer, then use the 

Application Manager to delete (or rename) the original application, before 

you begin the restore operation. 

To restore a local station application: 

1. On the production computer, on the desktop, click Start > All 

Programs > Rockwell Software > FactoryTalk View > Tools, and 

then click Application Manager.  

2. Select Site Edition (Local Station), and then click Next. 

Tip: To restore a local station application, the logged on user 
must have FactoryTalk administrative rights. If you 
receive a prompt to log on, check with your System 
Administrator. 

3. Select the restore operation, and then follow the instructions in the 

Application Manager to complete the operation. 

Move the local 
station application 
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About restoring System information with the 
application 

In FactoryTalk View Studio, in a local station application, the top-level 

System folder contains FactoryTalk Security information, including user 

accounts set up for all applications using the same FactoryTalk Local 

Directory (also called the Local Directory). 

When you back up a local station application, this FactoryTalk system 

information is saved to the archive automatically. When you restore a local 

station application, you can choose whether to restore the system information 

with the application. 

To restore FactoryTalk system information with the application: 

In the Application Manager tool, after specifying the archive to restore, 

select the option, Restore the FactoryTalk View SE (local station) 

application and FactoryTalk Local Directory. 

To complete the operation, the user logged on to the Application Manager 

must have FactoryTalk administrative rights at the Local Directory being 

restored. 

A FactoryTalk View SE local station application can contain one RSLinx 

Enterprise data server, which must be located on the same computer as the 

application. 

In addition, the local station application can contain one or more OPC data 

servers (RSLinx Classic, or some other OPC server), which can be located on 

remote computers. 

After ensuring that the required communications software is installed on 

production computers, for each remote OPC data server you are deploying, 

move the configuration files to the production computer and specify the new 

host computer name. 

Tip: For information about moving setup files for OPC data 
servers other than RSLinx Classic, see the product 
documentation for the OPC server. 

After installing RSLinx Enterprise, RSLinx Classic, or some other OPC 

server software on the production computer, if necessary, you can move the 

data server’s setup files to the computer. 

Back up and restore RSLinx Enterprise files 

When you back up a FactoryTalk View SE local station application, the 

archive includes RSLinx Enterprise shortcut names, but does not include 

device path information. 

Move data servers 
and change their 
properties 
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After restoring the application, you must open the Communications Setup 

editor in FactoryTalk View Studio, and re-apply the device path for each 

configured shortcut. 

For details, see Renew data server shortcuts, topics, and device paths on page 

68. 

Back up and restore RSLinx Classic configurations 

RSLinx Classic configuration files are not included when you back up an 

application. You have to back up, move, and restore the files manually. 

If RSLinx Classic is installed on the development and production computers, 

you can use the RSLinx Classic Backup/Restore tool to back up and restore 

configuration files. 

Tip: You can also restore RSLinx Classic configuration files 
from the Wizard Completed window of the RSLinx 
Classic software setup program. 

To move RSLinx Classic configuration files: 

1. On the development computer, click Start > All Programs > 

Rockwell Software > RSLinx, and then click RSLinx Classic 

Backup Restore Utility.  

2. In the RSLinx Classic Backup/Restore tool, click Backup. 

 

3. Select a folder for the backup file, type a file name, and then click 

Save. 

4. In Windows Explorer, copy the backup file (with .rsx extension), and 

then paste it into a location on the data server production computer. 

5. On the production computer, click Start > All Programs > Rockwell 

Software > RSLinx, and then click RSLinx Classic Backup Restore 

Utility. 

6. In the RSLinx Backup/Restore tool, click Restore. 
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7. Find and select the backup file you just pasted, and then click Open. 

After moving RSLinx Classic configuration files to production computers, 

open the restored local station application, and in the Properties dialog box 

for each data server, specify the name of the server’s host computer. 

Tip: Unlike RSLinx Classic data servers, you do not have to 
change the computer names of RSLinx Enterprise data 
servers. The RSLinx Enterprise data server in a local 
station application must be located on the same 
computer as the application, and is always named 
localhost. 

For information about setting up other data server properties, click Help in 

the server’s Properties dialog box, or see the product documentation. 

Tip: The first time you open an application after relocating a 
data server, if the server does not load, you should still 
be able to open the Properties dialog box and change 
the host computer name. After the computer name is 
updated, the server should load as expected. 

To change the RSLinx Classic server computer name: 

1. Open the restored application in the FactoryTalk Administration 

Console. To learn how to do this, see the previous task. 

2. In the Explorer window, expand the name of the restored application, 

right-click the RSLinx Classic server’s name, and then click 

Properties. 

3. In the General tab, in the field, Computer that will run the OPC 

server, type the name of the production computer, or click Browse to 

find and select the computer, and then click OK. 

In FactoryTalk View Studio, open the Properties dialog box for the HMI 

server in the application, to view the location of the HMI project files, the 

current number of displays in the application, and the maximum number of 

displays allowed. 

You can add a description for the HMI server and, in the Components tab, 

select components that will start when the HMI server starts running. 

Tip: In a local station application, the HMI server and the 
application have the same name. The name cannot be 
modified in the HMI server's Properties dialog box. 

To open the HMI Server Properties dialog box: 

1. Click Start > All Programs > Rockwell Software, and then click 

FactoryTalk View Studio. 

Specify OPC data 
server host 
computer names 

Specify when HMI 
server components 
start or stop 
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2. Select View Site Edition (Network Station), and then click Continue. 

3. Click the Existing tab, select the network station application’s name, 

and then click Open. 

4. In the Explorer window, right-click the HMI server’s name, and then 

click Properties. 

How HMI server components start and stop 

Use the HMI Server Properties dialog box to specify which components in a 

local station application will start automatically, when the HMI server starts 

running. 

In a network station or local station application, the HMI server loads and the 

specified components start running when the FactoryTalk View SE Client 

connects to the application. When the client stops running, the HMI server is 

unloaded, and the specified shutdown macro is run. 

You can also start or stop the HMI server components manually. To do this, 

in the Components tab, click Run Startup Components and Stop All 

Running Components, respectively. 

To select HMI server startup and shutdown components: 

1. In the HMI Server Properties dialog box, click the Components tab. 

2. To specify startup components, select the component check boxes, and 

then select the components you want to start automatically, when the 

HMI server starts running. 

3. To specify a shutdown macro, select the check box On shutdown 

macro, and then select the macro you want to run when the HMI 

server stops running. 

The FactoryTalk View SE Client provides a complete and secure run-time 

environment for a network station or local station application. For example, 

operators can use the client to: 

 Load, view, and interact with multiple graphic displays from the HMI 

server. 

 Manage alarm information. 

 View trends. 

 Adjust set points. 

 Start and stop server components. 

Set up the 
FactoryTalk View 
SE Client 
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To run a network station or local station application, the FactoryTalk View 

SE Client must run on the same computer as the HMI server. 

If you have already set up a FactoryTalk View SE Client file for the 

application, you can copy the file to the production computer. Otherwise, you 

can create a new client file. 

Create a new FactoryTalk View SE Client file 

FactoryTalk View SE Client configuration files specify the name of the 

application the client will connect to, the components that start when the 

connection is made, and how the client will behave at run time. 

To create a new client file, use the FactoryTalk View SE Client Wizard. You 

can also use the wizard to modify or run an existing client file, or to remove a 

client from the list of available files. 

Tip: It is not necessary to start the HMI server if you want to 
use the FactoryTalk View SE Client Wizard. 

To create a new FactoryTalk View SE Client file: 

1. On the desktop, select Start > All Programs > Rockwell Software > 

FactoryTalk View > FactoryTalk View Site Edition Client. 

2. In the FactoryTalk View SE Client Wizard, click New, and then follow 

the on-screen instructions. For details about options in the wizard, click 

Help. 

The client file is created with a .cli extension, in the location you 

specified. 

Lock operators into the run-time environment 

To lock operators into the FactoryTalk View SE Client at run time, for 

example, to prevent access to other programs on the computer, try one or 

more of the following methods: 

 Limit the ability to manipulate graphic displays, by removing the 

title bar or minimize and maximize buttons from selected displays. 

To do this, in the Display Settings dialog box, clear the check boxes 

Title Bar, Minimize Button, and Maximize Button. For details, see 

Chapter 16, Creating graphic displays in the FactoryTalk View Site 

Edition User’s Guide. 

 Limit the ability to manipulate the client window, by removing the 

title bar or minimize and maximize buttons from the client. 
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To do this, in the FactoryTalk View SE Client wizard, clear the check 

boxes, Show title bar, and Show system menu and close button. For 

details, click Help in the FactoryTalk View SE Client wizard. 

 Prevent switching to other applications. To do this, in the 

FactoryTalk View SE Client wizard, select the check box, Disable 

switch to other applications. For details, click Help in the 

FactoryTalk View SE Client wizard. 

 Restrict access to the desktop, using the DeskLock tool.   

To open Desklock, on the desktop click Start > All Programs > 

Rockwell Software > FactoryTalk View > Tools, and then click 

DeskLock.  

For details about using DeskLock, click Help within the tool. 

Note: Do not enable DeskLock until you read the help for the tool 
and understand how it works. Otherwise, you could end up 
locking yourself out of the desktop. 

 

Once the application is deployed, test it by running the FactoryTalk View 

SE Client. 

To run an SE Client using the .cli file: 

Double-click the client setup file (.cli), in the default folder 

C:\Users\Public\Public Documents\RSView Enterprise\SE\Client. 

To run an SE Client from FactoryTalk View Studio: 

1. In FactoryTalk View Studio, on the Tools menu, click Launch SE 

Client. 

2. In the FactoryTalk View SE Client Wizard dialog box, select the 

client configuration file from the list of most recently used files and 

click Run. To search for and select another file, click the browse 

button. 

To run an SE Client when Windows starts: 

1. Create a shortcut to the.cli file (on the desktop, for example). 

2. Move the shortcut to the Windows Startup folder. 

For information about adding shortcuts to the Startup folder, see the 

Windows Help 

Run the FactoryTalk 
View SE Client 
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Log on to the FactoryTalk View SE Client 

To start the FactoryTalk View SE Client, or to change users while the client 

is running, the user logging on must have the necessary security permissions. 

If the user does not have the necessary permissions, the FactoryTalk View 

SE Client login dialog box opens, to let another user log on. 

 

To make minor changes to an application after it is deployed, use either 

FactoryTalk View Studio or the FactoryTalk View SE Administration 

Console. The SE Administration Console contains the following subset of 

editors. 

To do this in the SE Administration Console Use this editor 

Change the properties of an HMI server. HMI Server Properties 

Change the properties of a data server. Data Server Properties 

Add FactoryTalk users to an application. Runtime Security 

Set up security for commands and macros. Secured Commands 

Run FactoryTalk View commands. Command Line 

Change how HMI tag alarms are logged. Alarm Setup 

Change the paths of data log models. Data Log Paths 

Manage HMI tag alarm log files. Alarm Log Setup 

Import and export HMI tags. Tag Import and Export Wizard 

For details about options in these editors, click Help. 

To open a local station application in FactoryTalk View Studio: 

1. Click Start > All Programs > Rockwell Software > FactoryTalk 

View > FactoryTalk View Studio. 

2. Select View Site Edition (Local Station), and then click Continue. 

3. In the Existing tab, select the restored application’s name, and then 

click Open. 

 

Administer 
deployed 
applications 
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Chapter 9 

Upgrade an operating FactoryTalk 

View SE network distributed 

application 

Upgrading the FactoryTalk View Site Edition software in an automation and 

control application involves two core tasks: uninstalling the existing software 

and then installing the new version. 

After installing the new software version, you should be able to open a 

FactoryTalk View SE application in FactoryTalk View Studio, and then run 

the application in a FactoryTalk View SE Client without any further 

intervention. 

Tip: Applications developed on versions 6.0 and earlier may 
need to be converted using the Legacy Tag Database 
Conversion Utility. Start the utility by clicking Start > 
Rockwell Software > FactoryTalk View > Tools > 
Legacy Tag Database Conversion Utility. For details 
about using the utility, click Help. 

However, depending on the design, content, and complexity of your control 

system, you might have to perform additional tasks to support the upgrade, 

especially if you are upgrading FactoryTalk View SE in a production 

environment. The information in this chapter will help you safeguard the live 

application, while ensuring that the upgrade process is efficient and 

successful. 

The upgrading steps vary depending on your application: 

 Upgrade a non-redundant network distributed application on page 100 

 Upgrade a redundant network distributed application on page 108 

As there are many possible variations for this type of application, parts of the 

documented process might not apply directly to the application you are 

upgrading. If you have questions about architectural elements not covered in 

this chapter, for example, your application is more or less complex than the 

example provided, contact your local Rockwell Automation Sales office for 

assistance. 
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Note: Before installing FactoryTalk View applications or any 
supporting software, review Hardware, operating system, and 
domain information on page 23, and ensure that you have 
performed the tasks that are appropriate to the role and 
configuration of each application host computer.  

Information to help you upgrade 

You can also look for answers in other Rockwell Automation product 

documentation, and on the Rockwell Automation Web site. See Open the 

FactoryTalk View online manuals on page 11. 

Tip: RSView Enterprise is the former name of the FactoryTalk 
View family of software products. If you are upgrading 
from a version of RSView, the information in this chapter 
still applies, even though it refers to FactoryTalk View as 
the previous product version. 

 

After upgrading all the software components in your deployed application, to 

find out about features in the new product version, see the product Release 

Notes. 

 The FactoryTalk View installation DVD or installation package 

contains the Release Notes of products such as FactoryTalk View SE, 

ME, and RSLinx Classic. 

 During installation, the Common Setup page shows links to the 

Release Notes of each product. 

 The Contents tab of the FactoryTalk Help also contains the Release 

Notes of each product. To open it, after installation, select Start > All 

Programs > Rockwell Software > FactoryTalk Tools > 

FactoryTalk Help. 

Use the following checklist as a guideline for upgrading your application. 

Details about each step are provided in this chapter. 

Part 1: Prepare for the upgrade 

 Step 1: Prepare for the upgrade on page 101 

 Step 2: Back up the deployed application on page 102 

Part 2: Perform upgrade of software components 

 Step 3: Shut down all client computers on page 103 

 Step 4: Upgrade the FactoryTalk Directory server on page 103 

 Step 5: Upgrade the HMI server on page 104 

 Step 6: Upgrade the data server on page 104 

Find out about 
features in the new 
product version 

Upgrade a 
non-redundant 
network distributed 
application 
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 Step 7: Upgrade the engineering workstation on page 105 

 Step 8: Migrate the application on page 105 

 Step 9: Upgrade all run-time clients on page 107 

 Step 10: Test the migrated application on page 107 

Example 

The following illustration shows an example of a FactoryTalk View SE 

network distributed application without redundant servers. 

In this example, Workstation #1 is the name of the engineering workstation. 

Assume that: 

 The FactoryTalk Directory server, HMI server, and data server are 

hosted on different computers. 

 The Tag Alarm and Event server and HMI server are hosted on the 

same computer. 

 

Step 1: Prepare for the upgrade 

Use the following multi-step checklist as a guideline when you prepare for 

the upgrade. For details, see procedures that follow. 

 Have the FactoryTalk View installation DVD or installation package 

on hand 

 Log on with administrative rights on page 102 

 Record the names and passwords of administrative users on page 102 

Part 1: Prepare for 
the upgrade 
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 Perform set-up tasks on application computers on page 102 

Log on with administrative rights 

To perform certain tasks, the user performing the upgrade must have 

administrative rights in Windows and at the FactoryTalk Network Directory. 

Windows administrative rights are required to install FactoryTalk View and 

supporting software because the Setup Wizard creates program folders and 

modifies registry entries. 

FactoryTalk administrative rights are required to log on to the FactoryTalk 

Network Directory, for example, when you use the FactoryTalk Directory 

Server Location Utility. 

To open the utility, you must log on as a FactoryTalk administrator on the 

local computer. To specify a remote Network Directory location, you must 

also have administrative rights on the remote computer. 

FactoryTalk administrative rights are also required to back up and restore 

FactoryTalk View SE applications. 

Record the names and passwords of administrative users 

Before backing up the deployed application, ensure that you have recorded 

the user names and passwords of users that belong to the FactoryTalk 

administrators group. 

Only members of the FactoryTalk administrators group can add, remove, or 

modify FactoryTalk user accounts, if this is necessary after restoring a 

backed-up application. 

Perform set-up tasks on application computers 

Before upgrading FactoryTalk View SE, review the chapter Hardware, 

operating system, and domain information on page 23. It contains 

information about tasks you can perform on application computers, to ensure 

that FactoryTalk View SE runs smoothly after it is installed. It also contains 

information about hardware and software requirements, and application 

limits. 

Step 2: Back up the deployed application 

Before backing up the deployed application, ensure that the most recent 

application data is available for the upgrade at the FactoryTalk Network 

Directory. 
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Use the Distributed Application Manager tool to back up the application. 

The backup archive has an .APB extension, and includes all FactoryTalk 

Directory data, such as accounts, passwords, policies and security settings. It 

also includes all application contents like application configurations, HMI 

servers, data servers, and tag Alarm and Event servers. 

Tip: RSLinx Classic configuration files are not included when 
you back up a FactoryTalk View SE application. You 
need to back up the RSLinx Classic configuration files 
before upgrading. For instructions, see Back up and 
restore RSLinx Classic configurations on page 67. 

To back up the application: 

1. On the HMI server, select Start > All Programs > Rockwell 

Software > FactoryTalk View > Tools > Distributed Application 

Manager. 

Tip: The logged on user must have the Backup and restore 
directory contents permission. For more information, 

see FactoryTalk Security Help or check with your System 
Administrator. 

2. In the Create a Backup tab, select your application and follow the 

wizard to back up the application. For more instructions, see 

Distributed Application Manager Help. 

Step 3: Shut down all client computers 

To disconnect the clients from the servers, shut down all run-time client 

computers, server computers, and Workstation #1. 

Step 4: Upgrade the FactoryTalk Directory server 

1. On the FactoryTalk Directory computer, close all open Windows 

programs. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 

Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Stand-alone FactoryTalk Directory 

Server and click Next. 

Part 2: Perform 
upgrade of software 
components 
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Tip: If you host the FactoryTalk Network Directory, HMI 
server, and data server on the same computer, select 
Studio Enterprise. 

4. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

5. After installation, install any necessary product updates. For 

instructions, see Install product updates on page 126. 

Tip: If you host the FactoryTalk Network Directory, HMI 
server, and data server on the same computer, skip to 
Step 7: Upgrade the engineering workstation on page 
105. 

 

Step 5: Upgrade the HMI server 

1. On the HMI server computer, close all open Windows programs. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 

Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Site Edition Server and click Next. 

4. If you have FactoryTalk Historian Management Tools installed, you 

need to manually uninstall the Management Tools Suite and the 

System Management Tools before installing FactoryTalk Historian 

Connectivity. For more information, see Rockwell Automation 

Answer ID 618193 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/6181

93 and the product documentation. 

5. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

6. After installation, install any necessary product updates. For 

instructions, see Install product updates on page 126. 

Step 6: Upgrade the data server 

1. On the RSLinx Enterprise data server computer, close all open 

Windows programs. 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/618193
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/618193
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/618193
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2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 

Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Stand-alone RSLinx Enterprise Server 

and click Next. 

4. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

5. After installation, install any necessary product updates. For 

instructions, see Install product updates on page 126. 

Step 7: Upgrade the engineering workstation 

1. On the engineering workstation computer, close all open Windows 

programs. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 

Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Studio Enterprise and click Next. 

4. If you have FactoryTalk Historian Management Tools installed, you 

need to manually uninstall the Management Tools Suite and the 

System Management Tools before installing FactoryTalk Historian 

Connectivity. For more information, see Rockwell Automation 

Answer ID 618193 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/6181

93 and the product documentation. 

5. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

6. After installation, install any necessary product updates. For 

instructions, see Install product updates on page 126. 

Step 8: Migrate the application 

Use the following checklist as a guideline when you migrate the FactoryTalk 

View SE application: 

 Open the application in FactoryTalk View Studio on page 106 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/618193
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/618193
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/618193
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 Verify RSLinx Enterprise shortcuts on page 106 

 Test the migrated application on page 106 

Open the application in FactoryTalk View Studio 

To migrate the application, open it in the new version of FactoryTalk View 

Studio installed on upgraded Workstation #1. 

To open the application: 

1. On Workstation #1, select Start > All Programs > Rockwell 

Software > FactoryTalk View > FactoryTalk View Studio. 

2. Select View Site Edition (Network Distributed) and then click 

Continue. 

3. In the Existing tab, click the application name, select an application 

language, and then click Open. 

4. If prompted to convert the application the new version, click OK. 

5. Wait until the HMI server and all project components in the application 

are loaded, and then leave the application open in FactoryTalk View 

Studio. 

Verify RSLinx Enterprise shortcuts 

To confirm that data communications are set up correctly in the migrated 

application, verify that RSLinx Enterprise shortcuts point at the correct 

devices. 

To verify RSLinx Enterprise shortcuts: 

1. In FactoryTalk View Studio, expand the data server RSLinx 

Enterprise, and then double-click Communications Setup. 

2. In the Communications Setup editor, select each configured RSLinx 

Enterprise shortcut, and ensure that it points at the correct device. 

3. Save the configuration and close the Communications Setup editor. 

Test the migrated application 

To test the migrated application, run the application on Workstation #1. 

1. On Workstation #1, start a FactoryTalk View SE Client configuration. 

2. Ensure that data communications are functioning as expected. 
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Step 9: Upgrade all run-time clients 

If you already have the Client Install Portal feature installed on the HMI 

server, you can upgrade the clients through a web browser. For detailed 

instructions, see Install SE clients in a distributed system on page 52. 

Otherwise, you can use the installation DVD or installation package. Follow 

the instructions below. 

1. On the client computers, close all software programs that are currently 

running. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 

Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Site Edition Client and click Next. 

4. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

After installation, install any necessary product updates. For instructions, see 

Install product updates on page 126. 

Step 10: Test the migrated application 

To test the migrated FactoryTalk View SE application, perform these tasks: 

 Run the migrated application on upgraded clients on page 107 

 Verify that the system is functioning as expected on page 107 

Run the migrated application on upgraded clients 

On each of the upgraded run-time client computers, run the existing 

FactoryTalk View SE Client configuration file (.cli). 

Verify that the system is functioning as expected 

After the application starts running on the upgraded client computers, verify 

that display navigation, object animation, communications, alarming (if 

configured), and other applications features are functioning as expected. 
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Upgrading a redundant system can be done in parts, allowing you to keep 

your system running without redundancy temporarily while you upgrade. 

During an upgrade, a temporary system can help you with verification and 

validation. 

Use the following multi-step checklist as a guideline for upgrading your 

redundant system. Details about each step are provided in this chapter. 

Part 1: Prepare for the upgrade 

 Step 1: Prepare for the upgrade on page 109 

 Step 2: Back up the application on Server #1 on page 110 

Part 2: Set up a separate system and perform a partial upgrade 

 Step 3: Set up a temporary upgrade system on page 112 

 Step 4: Upgrade Server #2 on page 115 

 Step 5: Upgrade Workstation #1 on page 115 

 Step 6: Migrate the application on page 115 

 Step 7: Upgrade selected run-time clients on page 117 

 Step 8: Test the migrated application on page 118 

Part 3: Upgrade remaining computers and restore redundancy 

 Step 9: Upgrade remaining client computers on page 119 

 Step 10: Upgrade Server #1 on page 120 

 Step 11: Restore redundancy and finish upgrading on page 121 

Example 

The following illustration shows an example of a FactoryTalk View SE 

network distributed application with redundant servers. 

In this example, Server #1 is the name of the primary server computer, 

Server #2 is the name of the secondary server computer, and Workstation 

#1 is the name of the engineering workstation. Assume that: 

 The FactoryTalk Directory server, primary data server, primary HMI 

server, and primary Tag Alarm and Event server are located on Server 

#1. 

Upgrade a 
redundant network 
distributed 
application 
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 The secondary data server, secondary HMI server, and secondary Tag 

Alarm and Event server are located on Server #2. 

 

Step 1: Prepare for the upgrade 

Use the following multi-step checklist as a guideline when you prepare for 

the upgrade. For details, see the procedures that follow. 

 Have the FactoryTalk View installation DVD or installation package 

on hand 

 Log on with administrative rights on page 109 

 Record the names and passwords of administrative users on page 110 

 Perform set-up tasks on application computers on page 110 

 Ensure that the latest application files are on the primary server on 

page 110 

Log on with administrative rights 

To perform certain tasks, the user performing the upgrade must have 

administrative rights in Windows and at the FactoryTalk Network Directory. 

Windows administrative rights are required to install FactoryTalk View and 

supporting software because the Setup Wizard creates program folders and 

modifies registry entries. 

FactoryTalk administrative rights are required to log on to the FactoryTalk 

Network Directory, for example, when you use the FactoryTalk Directory 

Server Location Utility. 

Part 1: Prepare for 
the upgrade 
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To open the utility, you must log on as a FactoryTalk administrator on the 

local computer. To specify a remote Network Directory location, you must 

also have administrative rights on the remote computer. 

FactoryTalk administrative rights are also required to back up and restore 

FactoryTalk View SE applications. 

Record the names and passwords of administrative users 

Before backing up the deployed application, ensure that you have recorded 

the user names and passwords of users that belong to the FactoryTalk 

administrators group. 

Only members of the FactoryTalk administrators group can add, remove, or 

modify FactoryTalk user accounts, if this is necessary after restoring a 

backed-up application. 

Perform set-up tasks on application computers 

Before upgrading FactoryTalk View SE, review the chapter Hardware, 

operating system, and domain information on page 23. It contains 

information about tasks you can perform on application computers, to ensure 

that FactoryTalk View SE runs smoothly after it is installed. It also contains 

information about hardware and software requirements, and application 

limits. 

Ensure that the latest application files are on the primary 

server 

During the upgrade described in this chapter, the application and HMI 

project files backed up on the primary server are restored on the secondary 

server, and then migrated in FactoryTalk View Studio on the upgraded 

engineering workstation. 

To ensure that you migrate and re-deploy the most recent application, ensure 

that the application and HMI project files you back up initially, on the 

primary server, are the most recent application files. 

Step 2: Back up the application on Server #1 

Before backing up the deployed application, ensure that the most recent 

application data is available for the upgrade on Server #1. 

Use the Distributed Application Manager tool to back up the application. 

The backup archive has an .APB extension, and includes all FactoryTalk 

Directory data, such as accounts, passwords, policies and security settings. It 

also includes all application contents like application configurations, HMI 

servers, data servers, and tag Alarm and Event servers. 
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Tip: RSLinx Classic configuration files are not included when 
you back up a FactoryTalk View SE application. You 
need to back up the RSLinx Classic configuration files 
before upgrading. For instructions, see Back up and 
restore RSLinx Classic configurations on page 67. 

To back up the application: 

1. On Server #1, select Start > All Programs > Rockwell Software > 

FactoryTalk View > Tools > Distributed Application Manager. 

Tip: The logged on user must have the Backup and restore 
directory contents permission. For more information, 

see FactoryTalk Security Help or check with your System 
Administrator. 

2. In the Create a Backup tab, select your application and specify the 

Host Machine as Server #1. 

3. Follow the wizard to back up the application on Server #1. For more 

instructions, see Distributed Application Manager Help. 

During this part, a temporary system is set up to test a partial upgrade that 

involves Server # 2, Workstation #1, and selected run-time clients. For the 

test, Server #2 is set up to function as the primary server. 

Tip: It is recommended that you upgrade the software on 
some application clients, confirm that the upgraded 
application is running as expected, and then upgrade the 
software on the remaining clients. The number of clients 
to upgrade initially is left to your discretion. 

 

Part 2: Set up a 
temporary system 
and perform a 
partial upgrade 
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Step 3: Set up a temporary upgrade system 

As part of the process, the original HMI project and application files that 

were backed up on Server #1 are restored on Server #2. The restored 

application will be migrated later, after Workstation #1 is upgraded. 

Note: To avoid introducing incompatible software component 
versions into a deployed production system, be sure to restore 
the HMI project and application files before upgrading any 
software. 

To set up a temporary system so that you can test a partial upgrade, perform 

the tasks below. For details, see the procedures that follow. 

 Disable HMI and data server redundancy in the original application on 

page 112 

 Copy the archive file to Server #2 on page 113 

 Specify Server #2 as the Network Directory location on page 113 

 Restore the application on Server #2 as the primary server on page 113 

 Specify Server #2 as the Network Directory location for Workstation 

#1 on page 113 

 Disable redundancy on Server #2 on page 114 

 Disable alarm and event history logging on page 114 

Disable HMI and data server redundancy in the original 

application 

To ensure that Server #2 can be detached from the application for upgrading, 

open the application in FactoryTalk View Studio, and disable redundancy for 

the HMI server and data server. 

To disable HMI and data server redundancy: 

1. On Workstation #1, open the application in FactoryTalk View Studio. 

2. In the Explorer window, right-click the HMI server and select 

Properties. 

3. In the Redundancy tab, clear the check box Provide redundancy 

using a secondary server, and click OK. 

4. In the Explorer window, right-click the data server RSLinx Enterprise 

and select Properties. 

5. In the Redundancy tab, clear the check box Provide redundancy 

using a secondary server, and click OK. 
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Copy the archive file to Server #2 

Move the archive file (*.apb) created on Server #1 to Server #2. 

Specify Server #2 as the Network Directory location 

1. On Server #2, select Start > All Programs > Rockwell Software > 

FactoryTalk Tools > Specify FactoryTalk Directory Location. 

Tip: To use the utility, you have to log on as an administrator 
on the local computer. 

2. Click the Browse button besides the field Computer hosting 

directory server. 

3. In the FactoryTalk Directory Server Configuration dialog box, 

select This computer and click OK. 

Tip: To change the Network Directory location, you have to 
log on as an administrator on the new Network Directory 
computer (local or remote). 

4. Click OK and then restart Server #2. 

Restore the application on Server #2 as the primary server 

1. On Server #2, select Start > All Programs > Rockwell Software > 

FactoryTalk View > Tools > Distributed Application Manager. 

Tip: The logged on user must have the Backup and restore 
directory contents permission. For more information, 

see FactoryTalk Security Help or check with your System 
Administrator. 

2. In the Restore an Archive tab, specify the restore scope as Restore 

application, with FactoryTalk Directory and the Primary Host as 

Server #2. 

3. Follow the wizard to restore the application. For more instructions, see 

Distributed Application Manager Help. 

Specify Server #2 as the Network Directory location for 

Workstation #1 

1. On Workstation #1, select Start > All Programs > Rockwell 

Software > FactoryTalk Tools > Specify FactoryTalk Directory 

Location. 
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Tip: To use the utility, you have to log on as an administrator 
on the local computer. 

2. Click the Browse button besides the field Computer hosting 

directory server. 

3. In the FactoryTalk Directory Server Configuration dialog box, 

select Remote computer, type Server #2 and click OK. 

Tip: To change the Network Directory location, you have to 
log on as an administrator on the new Network Directory 
computer (local or remote). 

4. Click OK and then restart Workstation #1. 

Disable redundancy on Server #2 

1. On Workstation #1, open the restored application in FactoryTalk 

View Studio. 

2. In the Explorer window, right-click the HMI server and select 

Properties. 

3. In the Redundancy tab, clear the check box Provide redundancy 

using a secondary server, and click OK. 

4. In the Explorer window, right-click the data server RSLinx Enterprise 

and select Properties. 

5. In the Redundancy tab, clear the check box Provide redundancy 

using a secondary server, and click OK. 

Disable alarm and event history logging 

After you restore the application, the alarm and event history logging is also 

enabled on Server #2. It is recommended that you disable the history 

logging. Follow the steps below. 

1. On Workstation #1, open the restored application in FactoryTalk 

View Studio. 

2. In the Explorer window, right-click the Tag Alarm and Event server 

and select Properties. 

3. In the Priorities and History tab, clear the Enable history check box 

and click OK. 
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Step 4: Upgrade Server #2 

To upgrade the software components, install FactoryTalk View SE and any 

necessary products updates on Server #2. 

1. On Server #2, close all open Windows programs. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 

Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Site Edition Server and click Next. 

4. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

5. After installation, install any necessary product updates. For 

instructions, see Install product updates on page 126. 

Step 5: Upgrade Workstation #1 

To upgrade the software components, install FactoryTalk View Studio and 

any necessary products updates on Workstation #1. 

1. On Workstation #1, close all open Windows programs. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 

Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Studio Enterprise and click Next. 

4. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

5. After installation, install any necessary product updates. For 

instructions, see Install product updates on page 126. 

Step 6: Migrate the application 

To migrate the FactoryTalk View SE application that was restored on Server 

#2, perform these tasks: 

 Open the application in FactoryTalk View Studio on page 116 
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 Verify RSLinx Enterprise shortcuts on page 116 

 Test the migrated application on page 116 

Open the application in FactoryTalk View Studio 

To migrate the application, open it in the new version of FactoryTalk View 

Studio installed on upgraded Workstation #1. 

To open the application: 

1. On Workstation #1, select Start > All Programs > Rockwell 

Software > FactoryTalk View > FactoryTalk View Studio. 

2. Select View Site Edition (Network Distributed) and then click 

Continue. 

3. In the Existing tab, click the application name, select an application 

language, and then click Open. 

4. If prompted to convert the application the new version, click OK. 

5. Wait until the HMI server and all project components in the application 

are loaded, and then leave the application open in FactoryTalk View 

Studio. 

Verify RSLinx Enterprise shortcuts 

To confirm that data communications are set up correctly in the migrated 

application, verify that RSLinx Enterprise shortcuts point at the correct 

devices. 

To verify RSLinx Enterprise shortcuts: 

1. In FactoryTalk View Studio, expand the data server RSLinx 

Enterprise, and then double-click Communications Setup. 

2. In the Communications Setup editor, select each configured RSLinx 

Enterprise shortcut, and ensure that it points at the correct device. 

3. Save the configuration and close the Communications Setup editor. 

Test the migrated application 

To test the migrated application, run the application on Workstation #1. 

1. On Workstation #1, start a FactoryTalk View SE Client configuration. 

2. Ensure that data communications are functioning as expected. 
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Step 7: Upgrade selected run-time clients 

To upgrade the software components, install FactoryTalk View SE Client 

and any necessary products updates on the selected run-time clients. Perform 

these tasks on each client computer. For details, see the procedures that 

follow. 

 Install FactoryTalk View SE Client on page 117 

 Specify Server #2 as the Network Directory location on client 

computers on page 117 

Install FactoryTalk View SE Client 

If you already have the Client Install Portal feature installed on the HMI 

server, you can upgrade the clients through a web browser. For detailed 

instructions, see Install SE clients in a distributed system on page 52. 

Otherwise, you can use the installation DVD or installation package. Follow 

the instructions below. 

1. On the client computers, close all software programs that are currently 

running. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 

Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Site Edition Client and click Next. 

4. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

5. After installation, install any necessary product updates. For 

instructions, see Install product updates on page 126. 

Specify Server #2 as the Network Directory location on 

client computers 

After upgrading the software on the client computer, specify Server #2 as the 

Network Directory location. 

To specify Server #2 as the Network Directory: 

1. On each of the client computers, select Start > All Programs > 

Rockwell Software > FactoryTalk Tools > Specify FactoryTalk 

Directory Location. 
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Tip: To use the utility, you have to log on as an administrator 
on the local computer. 

2. Click the Browse button besides the field Computer hosting 

directory server. 

3. In the FactoryTalk Directory Server Configuration dialog box, 

select Remote computer, type Server #2 and click OK. 

Tip: To change the Network Directory location, you have to 
log on as an administrator on the new Network Directory 
computer (local or remote). 

4. Click OK and then restart the client computer. 

Step 8: Test the migrated application 

To test the migrated application before upgrading remaining application 

computers, perform these tasks: 

 Start Server #2 and wait for it to finish starting on page 118 

 Run the migrated application on upgraded clients on page 119 

 Verify that the system is functioning as expected on page 119 

Start Server #2 and wait for it to finish starting 

If Server #2 is not already started, start the server and wait for the server to 

finish starting. 

To confirm that Server #2 has finished starting: 

1. On Server #2, select Start > All Programs > Rockwell Software > 

FactoryTalk Tools > Diagnostics Viewer. 

2. In the FactoryTalk Diagnostics Viewer, check for the following 

Diagnostics message: 

The HMI Server <ApplicationName>//Server #2 is the 

active server. 

Tip: To find a message faster in the Diagnostics Viewer, on 
the View menu, click Options. Then, in the Filter tab, 
create a Message filter with one or more keywords from 

the message. 
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Run the migrated application on upgraded clients 

On each of the upgraded run-time client computers, run the existing 

FactoryTalk View SE Client configuration file (.cli). 

Verify that the system is functioning as expected 

After the application starts running on the upgraded client computers, verify 

that display navigation, object animation, communications, alarming (if 

configured), and other applications features are functioning as expected. 

This part involves upgrading the remaining run-time clients and Server # 1, 

and restoring the redundancy. After upgrading, Server #2 becomes the 

primary server and Server #1 becomes secondary. 

Step 9: Upgrade remaining client computers 

After testing the partially upgraded system, on the remaining client 

computers, install FactoryTalk View SE Client and point at Server #2 as the 

Network Directory. Perform these tasks: 

 Install FactoryTalk View SE Client on page 117 

 Specify Server #2 as the Network Directory for remaining clients on 

page 117 

Install FactoryTalk View SE Client 

If you already have the Client Install Portal feature installed on the HMI 

server, you can upgrade the clients through a web browser. For detailed 

instructions, see Install SE clients in a distributed system on page 52. 

Otherwise, you can use the installation DVD or installation package. Follow 

the instructions below. 

1. On the client computers, close all software programs that are currently 

running. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 

Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Site Edition Client and click Next. 

4. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

Part 3: Upgrade 
remaining clients 
and restore 
redundancy 
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5. After installation, install any necessary product updates. For 

instructions, see Install product updates on page 126. 

Specify Server #2 as the Network Directory location on 

client computers 

After upgrading the software on the client computer, specify Server #2 as the 

Network Directory location. 

To specify Server #2 as the Network Directory: 

1. On each of the client computers, select Start > All Programs > 

Rockwell Software > FactoryTalk Tools > Specify FactoryTalk 

Directory Location. 

Tip: To use the utility, you have to log on as an administrator 
on the local computer. 

2. Click the Browse button besides the field Computer hosting 

directory server. 

3. In the FactoryTalk Directory Server Configuration dialog box, 

select Remote computer, type Server #2 and click OK. 

Tip: To change the Network Directory location, you have to 
log on as an administrator on the new Network Directory 
computer (local or remote). 

4. Click OK and then restart the client computer. 

Step 10: Upgrade Server #1 

To upgrade FactoryTalk View SE and supporting software on Server #1, 

install FactoryTalk View SE Server and set up Server #1 to point at Server 

#2. Perform these tasks: 

 Install FactoryTalk View SE Server on page 120 

 Specify Server #2 as the Network Directory for Server #1 on page 121 

Install FactoryTalk View SE Server on Server #1 

1. On Server #1, close all open Windows programs. 

2. Place the FactoryTalk View installation DVD in the computer’s DVD 

drive, or double-click Setup.exe within the installation package. 
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Tip: If the DVD does not start automatically, run 
D:\Setup.exe, where D: is the drive containing the DVD. 

3. On the Welcome page, select Site Edition Server and click Next. 

4. Follow the instructions to finish the installation. For more information, 

see the chapter Install FactoryTalk View on page 37. 

5. After installation, install any necessary product updates. For 

instructions, see Install product updates on page 126. 

Specify Server #2 as the Network Directory for Server #1 

1. On Server #1, select Start > All Programs > Rockwell Software > 

FactoryTalk Tools > Specify FactoryTalk Directory Location. 

Tip: To use the utility, you have to log on as an administrator 
on the local computer. 

2. Click the Browse button beside the field Computer hosting directory 

server. 

3. In the FactoryTalk Directory Server Configuration dialog box, 

select Remote computer, type Server #2, and then click OK. 

Tip: To change the Network Directory location, you have to 
log on as an administrator on the new Network Directory 
computer (local or remote). In this case, the new location 
is remote. 

4. Click OK again, and then restart Server #1. 

Step 11: Restore redundancy and finish upgrading 

Before finishing the upgrade, you need to enable the redundancy and check 

the server status. If the status is not right, restart Server #1 and Server #2. 

Perform the following tasks: 

 Enable HMI and data server redundancy on page 121 

 Enable alarm and event history logging on page 122 

 Confirm the status of primary and secondary servers on page 122 

 Start all run-time clients on page 123 

Enable HMI and data server redundancy 

1. On Workstation #1, open the application in FactoryTalk View Studio. 
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2. In the Explorer window, right-click the HMI server and select 

Properties. 

3. In the Redundancy tab, select the check box Provide redundancy 

using a secondary server. 

4. Under the Secondary Server area, type Server #1 and click OK. 

5. In the Explorer window, right-click the data server RSLinx Enterprise 

and select Properties. 

6. In the Redundancy tab, select the check box Provide redundancy 

using a secondary server. 

7. Under the Computer running secondary server field, type Server #1 

and click OK. 

Enable alarm and event history logging 

If the alarm and event history logging is already disabled on Server #2, 

follow the steps below to enable the history logging. 

1. On Workstation #1, open the restored application in FactoryTalk 

View Studio. 

2. In the Explorer window, right-click the Tag Alarm and Event server 

and select Properties. 

3. In the Priorities and History tab, select the Enable history check 

box, select the database and click OK. 

Confirm the status of primary and secondary servers 

On Workstation #1, in FactoryTalk View Studio, right-click the HMI server 

and then select Server Status. 

In the Server Status dialog box: 

 Server #2 and Active status are displayed in the fields Primary server 

and Primary status respectively. 

 Server #1 and Standby status are displayed in the fields Secondary 

server and Secondary status respectively. 

Tip: To switch the Active server to Server #1, click 
Switchover. 
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Start all run-time clients 

To ensure that the entire, upgraded application is functioning as expected, 

run the existing FactoryTalk View SE Client configuration file on each 

run-time client computer. 
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Appendix A 

Common upgrade procedures 

This section contains notes, common procedures and information from the 

Rockwell Automation Knowledgebase that you may find helpful during 

installation of FactoryTalk View products. 

Procedures in this section are: 

 Recreate SQL Server 2008 R2 Express instance on page 125. 

 Install product updates on page 126. 

SQL Server 2008 R2 Express instance FTVIEWx64TagDB is created to store 

all the FactoryTalk View SE Tags and HMI Alarms data, which HMI Server 

and View Studio will access. You need to recreate SQL Server 2008 R2 

Express instance FTVIEWx64TagDB manually under the following cases: 

 For some reason you need to uninstall SQL Server 2008 R2 Express 

instance FTVIEWx64TagDB and reinstall it. 

 On a computer that has had only the FactoryTalk View SE Client 

installed previously. 

A message shows up asking the user to recreate the SQL server instance if 

user has not done so. 

Tip: If you are installing FactoryTalk View with an existing 
SQL server, see Rockwell Automation Knowledgebase 
Answer ID 463910 
http://rockwellautomation.custhelp.com/cgi-bin/rockwella
utomation.cfg/php/enduser/std_adp.php?p_faqid=463910
\n. 

To recreate SQL Server 2008 R2 Express instance: 

1. If necessary, close all open Windows programs, and then place the 

FactoryTalk View Site Edition DVD in the computer’s DVD drive. 

2. Locate and run 

D:\Redist\SQLServerEXPR_2008R2SP2\SQLServerInstall.exe 
where D:\ is the drive containing the DVD. 

Recreate SQL 
Server 2008 R2 
Express instance 

http://rockwellautomation.custhelp.com/cgi-bin/rockwellautomation.cfg/php/enduser/std_adp.php?p_faqid=463910/n
http://rockwellautomation.custhelp.com/cgi-bin/rockwellautomation.cfg/php/enduser/std_adp.php?p_faqid=463910n
http://rockwellautomation.custhelp.com/cgi-bin/rockwellautomation.cfg/php/enduser/std_adp.php?p_faqid=463910n
http://rockwellautomation.custhelp.com/cgi-bin/rockwellautomation.cfg/php/enduser/std_adp.php?p_faqid=463910n
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Tip: Windows Installer 4.5 and .NET Framework 3.5 SP1 are 
required for this procedure. 

3. Input and confirm a password for the SA account in the SQL Server 

Install window, and then click OK. Click Guidelines for quick 

reference of SQL SA User Strong Password Guidelines or see page 42. 

4. To finish installing the software, follow the instructions in the wizard. 

After installing FactoryTalk View SE, you should locate and install patches 

for the software products on your system. To locate patches, search the 

Rockwell Automation Knowledgebase for Patch TOCs (Tables of Contents). 

The TOCs contain lists of all available patches for your software. Go to 

http://rockwellautomation.custhelp.com and select the Search 

Knowledgebase tab. 

A Patch TOC describes updates released for a particular product and version, 

and provides instructions for downloading and installing the updates on 

computers where the software is installed. 

To find Patch TOCs in the Rockwell Automation Knowledgebase: 

1. In your Web browser address bar, type 

www.rockwellautomation.custhelp.com, then press Enter. 

2. On the Rockwell Automation Support Center page, click the down 

arrow on the Search Knowledgebase tab. Select By Product. 

 

Install product 
updates 
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3. Scroll down to Software and click on FactoryTalk View SE. In the 

Search box, type Patch TOC and click Search. 

 

In the search results, look for Patch TOCs related to all the products 

you installed from the FactoryTalk View Site Edition DVD. If 

necessary, conduct additional searches for other newly-installed 

applications, including: 

 SE Client 

 SE Server 

 SE Station 

 Studio Enterprise 

 FactoryTalk Services Platform 

 FactoryTalk Alarms and Events 

 RSLinx Enterprise 

 RSLinx Classic 
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Appendix B 

FactoryTalk tools and utilities 

To run the following tool, select Start > All Programs > Rockwell 

Software > FactoryTalk View > Uninstall FactoryTalk View. 

 Uninstall FactoryTalk View is a utility for uninstalling FactoryTalk 

View components that are already installed on your computer. It does 

not uninstall components, like RSLinx Classic and FactoryTalk 

Activation Manager, that are shared with other products. You need to 

manually uninstall them in Control Panel. 

You can also choose to remove all FactoryTalk View application files, 

for example, archives and HMI project files. 

To run the following set of tools, select Start > All Programs > Rockwell 

Software > FactoryTalk View > Tools, and then click the tool you want to 

run. 

 Alarm Migration is software to migrate traditional HMI alarms to 

FactoryTalk Alarms and Events tag-based alarms. 

 Application Documenter is a stand-alone utility that provides detailed 

information on FactoryTalk View SE and ME applications. This utility 

is a browser that allows you to view the contents of the application’s 

components and the tags used in these components. You can also print 

and export the information. 

 Application Manager is software for renaming, copying, deleting, 

backing up, and restoring FactoryTalk View SE Station and 

FactoryTalk View ME applications. 

For FactoryTalk View SE network applications, use the Application 

Manager to rename and delete an application only. 

 DeskLock is software that prevents users of FactoryTalk View 

SE Client and FactoryTalk View ME from gaining access to the 

Windows desktop and system keys. 

 Distributed Application Manager is software to back up or restore 

network distributed applications within a single tool at a time.  

 FactoryTalk View File Viewer is software to view and save log files 

like SE datalog files, ME datalog files, ME alarm log files, dBASE file, 

and ME RecipePlus files. 

 FactoryTalk View SE Cache Management Tool is software to 

manage the temporary files of HMI Server components. 

FactoryTalk View 
tools 
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 FactoryTalk View SE Secure Web Site Setup is software for setting 

up secure access to application components under IIS (Internet 

Information Services). 

 FTVIEWUSER Account Reset is software for resetting the 

FTVIEWUSER SQL account back to its default. 

 HMI Server Backup and Restore is a utility for backing up 

FactoryTalk View SE HMI servers while they are running. Use this 

utility when backing up or restoring a stand-alone system, or when 

deploying a distributed system from one set of computers to another. 

 Legacy Tag Database Conversion Utility is software for converting 

your legacy tag database (before View 6.0) to a new format to work 

with Microsoft SQL database. 

 SE HMI Tag Alarm Log Setup is software for setting up HMI tag 

alarm logging. 

 SE HMI Tag Alarm Log Viewer is software for viewing the contents 

of HMI tag alarm log files. 

 SE Service Manager is a tool that allows you to stop or start the 

FactoryTalk View HMI Service manually on the computer. 

 Tag Import and Export Wizard is software for importing or 

exporting the FactoryTalk View SE Server’s tag database. 

To run the following set of tools, select Start > All Programs > Rockwell 

Software > FactoryTalk Tools, and then click the tool you want to run. 

 Diagnostics Counter Monitor is software to check the status of tags 

and to monitor the runtime values of counters and strings that are made 

available by network clients for diagnostic purposes. 

 Diagnostics Viewer is software for viewing the contents of 

FactoryTalk Diagnostics logs, to help with troubleshooting the system. 

 FactoryTalk Directory Configuration Wizard is software for setting 

up the FactoryTalk Network Directory or Local Directory on the 

computer. 

 Import RSSecurity Configuration is software for importing 

RSSecurity setup information to FactoryTalk Security. 

 Log On to FactoryTalk is software for logging users on and off the 

FactoryTalk Directory. 

 Rockwell Software Data Client is diagnostic software for testing 

client and server data connections in an application. 

 RSSecurity Emulator Install is software for installing the RSSecurity 

Emulator, which emulates an RSSecurity Server for legacy products. 

 Specify FactoryTalk Directory Location is software for specifying 

which computer on the network contains the FactoryTalk Network 

Directory service. 

FactoryTalk tools 
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 Windows Firewall Configuration Utility is software for configuring 

firewall settings for FactoryTalk View. 
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Appendix C 

Install Microsoft Internet 

Information Services 

When you install FactoryTalk View SE , IIS is installed by FactoryTalk 

View Setup Wizard automatically. This appendix servers as a reference to 

help you troubleshoot issues and verify IIS settings. 

You must install IIS for FactoryTalk View SE network applications: 

 on all computers that will run FactoryTalk View SE Servers (also 

called HMI servers). 

 on engineering workstations that will run all the FactoryTalk View SE 

software components. 

You do not have to install IIS if you plan to develop and run only 

FactoryTalk View SE local applications.  

If necessary, you can install IIS from your Microsoft Windows operating 

system DVD. 

1. Open Windows Control Panel, and click Programs. 

2. Under Programs and Features, click Turn Windows features on or 

off. The Windows Features dialog box will open. 

3. Click the checkbox to the left of Internet Information Services to 

enable settings. 

4. Expand the Web Management Tools folders, and then expand the IIS 

6 Management Compatibility folder. 

5. Select the IIS Metabase and IIS 6 configuration compatibility check 

box. 

6. Expand the World Wide Web Services folder and then expand the 

Application Development Features folder. 

7. Select the ASP check box. The ISAPI Extensions check box should 

then be selected automatically. 

8. Under the World Wide Web Services folder, expand the Common 

HTTP Features folder. 

Install IIS on 
Windows 8.1, 
Windows 8, or 
Windows 7 
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9. Select the WebDAV Publishing checkbox. 

10. Under World Wide Web Services folder, expand the Security folder. 

11. Select the Windows Authentication and URL Authorization check 

boxes. 

Tip: If IIS is installed correctly, you should be able to open the 
HMI server status page on localhost first, then from 
another computer. To test this, open Internet Explorer, in 
the address field, type http://localhost/rsviewse, or 
http://computername/rsviewse then the Enter key. 

 

The steps vary slightly. Follow the on-screen instructions that apply to the 

operating systems you are using. 

1. Select Start > Administrative Tools > Server Manager. 

2. (Windows Server 2008) In the Server Manager window, under Roles 

Summary, click Add Roles. 

(Windows Server 2012) In the Server Manager Dashboard window, 

click Add roles and features. 

3. Use the Add Roles Wizard (or Add Roles and Features Wizard) to add 

the Web Server (IIS) role. 

4. To install the Web Server, some additional Windows features might 

need to be installed. In each case, click Add Required Features. 

5. In the Add Role Services (or Add Server Roles) page, expand 

Common HTTP Features, and then select WebDAV Publishing. 

Tip: If you are running on Windows Server 2008 Standard 
Edition with Service Pack 2, the steps to install WebDAV 
are different. See Install WebDAV on Windows Server 
2008 on page 136. 

6. Click to expand Security, and then select the Windows 

Authentication and URL Authorization check boxes. 

7. Click to expand Application Development, and then select ASP. 

8. When prompted to install ISAPI Extensions, click Add Required Role 

Services. 

Install IIS on 
Windows Server 
2008 or Server 2012 
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The following example shows the installation for Windows Server 

2008. 

 

9. Click to expand Management Tools and then expand IIS 6 

Management Compatibility. 

10. Under IIS 6 Management Compatibility, select IIS 6 Metabase 

Compatibility. 

The following example shows the installation for Windows Server 

2008. 
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11. Click Next, and then accept the default selections at each remaining 

step of the wizard by clicking Next until all of the steps are complete. 

12. At the end of the wizard, click Install to install the Web Server role. 

13. After you have installed the Web Server role, install WebDAV, as 

described in the next section. 

WebDAV allows remote clients to connect to HMI servers located on a 

computer running Windows Server 2008 Standard Edition with Service Pack 

2. 

With Windows Server 2008 Standard Edition with Service Pack 2, Microsoft 

no longer automatically distributes the IETF WebDAV extensions to HTTP 

(as defined in RFC 2518). For Windows Server 2008 Standard Edition with 

Service Pack 2, download and then install these extensions from Microsoft 

at: 

Microsoft WebDAV Extension for IIS 7.0 (x86 or x64) 

http://www.iis.net/download/webDAV 

Tip: If IIS is installed correctly, you should be able to open the 
HMI server status page. To test this, on the desktop click 
Start, click Run, type http://localhost/rsviewse, and 
then press Enter. 

 

 

Install WebDAV on 
Windows Server 
2008 
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Appendix D 

Use unattended installation 

The unattended installation is an automated installation method that you can 

use to install FactoryTalk View. You can typically use the unattended 

installation during large-scale rollouts when it might be too slow and costly 

to have administrators or technicians interactively install the FactoryTalk 

View software on individual computers. 

In the unattended installation, you enter a specified command line with 

multiple parameters. During the installation process, instead of prompting 

you for installation and configuration information interactively, the process 

follows the parameters you specified in the command lines. 

Before installation, keep in mind: 

 If you are using Windows Server 2012 R2, Windows Server 2012, 

Windows 8.1, or Windows 8, .NET Framework 3.5 is required. You 

need to manually install it first. For detailed instructions, refer to 

http://msdn.microsoft.com/en-us/library/hh506443.aspx. 

 If you are using Windows Server 2008 SP2, you need to install 

WebDAV manually. For detailed instructions, see Install WebDAV on 

Windows Server 2008 on page 136. 

 If you use RSNetWorx on your computer, RSNetWorx v10.00 or later 

is required. We recommend that you upgrade it to v21.00 or later. 

1. Close all open Windows programs. 

2. Open the Command Prompt window: 

 (Windows Server 2012, Windows 8.1, and Windows 8) Press the 

Windows button+R. In the Open text box, input cmd and click 

OK. 

 (The other supported operating systems) From the Windows Start 

menu, select All Programs > Accessories > Command Prompt. 

3. In the Command Prompt window, navigate to D:\, where D:\ is the 

drive containing the FTView installation DVD. 

In this example, type D: and press Enter. 

4. Type a command line with the following syntax: 

Setup /Q 

Perform unattended 
installation 
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/AcceptAllLicenseItems 

/Product=product_name 

[/AdobeReader] 

[/UserName=user_name] 

[/Organization=organization_name] 

[/SqlSaPwd=sql_server_password] 

[/SerialNumber=serial_number] 

[/ProductKey=product_key] 

[/AutoRestart] 

After you press Enter, the installation process starts with the 

parameters you specified. 

For detailed description about each parameter, see Parameters on page 

138. You can also type Setup /? in the Command Prompt window, and 

press Enter to view the help information of all parameters and 

examples. 

Tip: The User Account Control dialog box may show after you 
press Enter, click Yes to continue. The unattended 

installation requires the administrator permission. 

 

The parameters and values are not case sensitive. If the value includes 

spaces, you need to enclose it in quotation marks (" "). 

If your installation package is Personalized Edition, the following parameters 

will be ignored during installation: 

 /UserName 

 /Organization 

 /SerialNumber 

 /ProductKey 

/Q 

(Required) Specifies whether to use the unattended installation. 

If omitted, the other parameters will not take effect and the installation 

will start with Setup Wizard. 

/AcceptAllLicenseItems 

(Required) Specifies that you read and acknowledge all license 

agreements, and agree to continue the unattended installation. 

If omitted, you cannot continue the installation. 

/Product=product_name 

Parameters 
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(Required) Specifies which product will be installed. The value must 

be quoted by quotation marks (" "), for example,  /Product="Studio 

Enterprise". 

The product name must be the one of following: 

 Studio Enterprise 

 Site Edition Server 

 Site Edition Client 

 Site Edition Station 

 Stand-alone RSLinx Enterprise Server 

 Stand-alone FactoryTalk Directory Server 

/AdobeReader 

(Optional) Specifies whether to install Adobe Reader. 

If omitted, Adobe Reader will not be installed. 

/UserName=user_name 

(Optional) Specifies the user name. 

/Organization=organization_name 

(Optional) Specifies the organization name. 

/SQLSAPWD=sql_server_password 

(Optional) Specifies the password for the Microsoft SQL Server SA 

(System Administrator) account. The value must meet strong password 

policy requirements. 

The parameter is required when you are installing one of the following 

products: 

 Studio Enterprise 

 Site Edition Server 

 Site Edition Station 

/SerialNumber=serial_number 

(Optional) Specifies the product serial number. 

If you want to get activation keys during installation, the parameter is 

required. 
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/ProductKey=product_key 

(Optional) Specifies the product key. 

If you want to get activation keys during installation, the parameter is 

required. 

/AutoRestart 

(Optional) Specifies whether to restart the computer automatically after 

the installation. 

If it is specified, the computer will be restarted automatically after the 

installation. 

If it is not specified, you will be prompted to restart the computer after 

the installation. 

You can find the installation logs and check the installation status in 

the following directory: 

 (32-bit operating systems) C:\Program Files\Common 

Files\Rockwell\Install Logs 

 (64-bit operating systems) C:\Program Files (x86)\Common 

Files\Rockwell\Install Logs 

The following examples show how to use the commands during the 

unattended installation. 

Example 1 

Setup /Q /AcceptAllLicenseItems /Product="Studio 

Enterprise" /AdobeReader /SqlSaPwd=myPassword@123 

/SerialNumber=0123456789 /ProductKey=ABCDE-FGHIJ 

means: 

 FactoryTalk View Studio Enterprise will be installed. 

 Adobe Reader will be installed. 

 Microsoft SQL Server will be installed and the system administrator 

password will be myPassword@123. 

 The setup will get activation keys during installation if the serial 

number 0123456789 and product key ABCDE-FGHIJ are valid. 

Examples 
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Example 2 

Setup /Q /AcceptAllLicenseItems /Product="Site Edition 

Client" /AutoRestart 

means: 

 FactoryTalk View Site Edition Client will be installed. 

 The computer will be restarted automatically after the installation. 
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product notification updates. 
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http://www.rockwellautomation.com/services/online-phone. 

Installation assistance 
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United States or Canada 1.440.646.3434 

Outside United States or Canada Use the Worldwide Locator available at http://www.rockwellautomation.com/locations 
http://www.rockwellautomation.com/locations, or contact your local Rockwell 
Automation representative. 

 

New product satisfaction return 

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. 

However, if your product is not functioning and needs to be returned, follow these procedures. 

United States Contact your distributor. You must provide a Customer Support case number (call the 
phone number above to obtain one) to your distributor to complete the return process. 

Outside United States Please contact your local Rockwell Automation representative for the return procedure. 
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